Bug 1264942 - systemd error 'FreezingExecution' on reboot with dnf-system-upgrade
systemd error 'FreezingExecution' on reboot with dnf-system-upgrade
Status: CLOSED DUPLICATE of bug 1245838
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 13:14 EDT by Satish Balay
Modified: 2015-09-21 14:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 14:25:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2015-09-21 13:14:16 EDT
Description of problem:

Reboot after dnf-system-upgrade gives systemd error 'FreezingExecution'
Version-Release number of selected component (if applicable):

This is on a Thinkpad T430 laptop.

How reproducible:

I've seen this error before with 'fedup' a couple of days ago [before it was obseleted by dnf-system-upgrade aswell]. But I was able to reboot back to F22 kernel [and do "fedup --resetbootloader"]


Steps to Reproduce:
[from F22] 
1. fedup --network 23
2. dnf system-upgrade reboot
3.

Actual results:

[transcribing message manually from screen]

systemd[1]: [/etc/systemd/system/system-upgrade-shell.service:8] couldn't unescape assignment, ignoring: TERM=linux ps1=system-upgrade:\w\$\x20
systemd[1]: caught <ABRT dumped core as pid200.
systemd[1]: FreezingExecution

Expected results:

Continue of upgrade process.

Additional info:

Current F23 beta snapshot is: 23_Beta_RC1/Workstation
Comment 1 Will Woods 2015-09-21 14:25:05 EDT
system-upgrade-shell.service only exists in the (now obsolete) upgrade.img that the old fedup uses. So you're still booting the old upgrade boot entry, which we know is broken and useless.

You should delete that boot entry:

  new-kernel-pkg --remove fedup

*** This bug has been marked as a duplicate of bug 1245838 ***

Note You need to log in before you can comment on or make changes to this bug.