Bug 1264950 - Logic issues with displaying of status of resource group in web UI dashboard.
Logic issues with displaying of status of resource group in web UI dashboard.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Feist
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 13:28 EDT by Miroslav Lisik
Modified: 2015-11-13 09:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 09:07:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Lisik 2015-09-21 13:28:22 EDT
Description of problem:

When you have a resource group with more than one resource and the resources have issues, then color of group status is not set according to the issue with highest priority on the dashboard in pcs web UI.

Version-Release number of selected component (if applicable):
pcs-0.9.143-9.el7.x86_64

How reproducible:
always

Steps to Reproduce:

1. Setup resource group.

[root@virt-028 ~]# pcs resource create before Dummy --group apache-group
[root@virt-028 ~]# pcs resource create apache apache --group apache-group
[root@virt-028 ~]# pcs resource 
 Resource Group: apache-group
	 before	(ocf::heartbeat:Dummy):	Started virt-028
	 apache	(ocf::hea.rtbeat:apache):	Started virt-028

2. Cause apache failure.

Move apache configuration file on all cluster nodes.
[root@virt-028 ~]# mv /etc/httpd/conf/httpd.conf ~/httpd.conf

The apache-group has status of "partially running" with red color and "Failed" icon and cluster has "Warning" icon
and it is counted as warning on the top row.

3. Cause a failed action on the 'before' resource.
[root@virt-028 ~]# crm_resource --resource before --fail -H virt-028

Color of status changed from red to orange. Cluster is counted under "Warning" icon.

Actual results:
The color of status of resource group is not set according to resource with higher priority issue.
(e.g. in resource group is a running resource with one failed monitor action and stopped apache resource with failed action - resource group status is "partially running" with orange color)

Expected results:
When you have more resources in a resource group, then status of resource group has color according to resource with higher priority issue.
Comment 1 Miroslav Lisik 2015-11-13 09:07:32 EST
I am not able to reproduce this anymore with pcs-0.9.143-15.el7.

Note You need to log in before you can comment on or make changes to this bug.