Bug 1264959 - Incorrect message when trying to remove nonexistent network from a host
Incorrect message when trying to remove nonexistent network from a host
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.0-rc3
: 3.6.0.2
Assigned To: Barak
Michael Burman
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 13:58 EDT by Yevgeny Zaspitsky
Modified: 2016-02-10 14:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:54:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.0?
rule-engine: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46477 master MERGED engine: Fix NETWORK_ATTACHMENTS_NOT_EXISTS message Never
oVirt gerrit 46494 ovirt-engine-3.6 MERGED engine: Fix NETWORK_ATTACHMENTS_NOT_EXISTS message Never

  None (edit)
Description Yevgeny Zaspitsky 2015-09-21 13:58:15 EDT
Description of problem:
When trying to remove a nonexistent network from a host the following message appears:
Following Network Attachments does not exist: ${NETWORK_ATTACHMENT_NOT_EXISTS_LIST}.

"${NETWORK_ATTACHMENT_NOT_EXISTS_LIST}" does not get converted into an actual network attachment Id.

Version-Release number of selected component (if applicable):
3.6/master

How reproducible:
100%

Steps to Reproduce:
1. Create a non-required network and add that to a host. 
2. Open another (2nd) webadmin UI in another browser
3. Open setup networks dialog for the host in both browsers
4. Remove the added network from the host in one of the browsers
5. Submit the same request in the 2nd browser after the 1st one has finished removing the network

Actual results:

"Following Network Attachments does not exist: ${NETWORK_ATTACHMENT_NOT_EXISTS_LIST}." message appears in the 2nd browser.

Expected results:

${NETWORK_ATTACHMENT_NOT_EXISTS_LIST} get translated into the actual network attachment Id.

Additional info:
Comment 1 Oved Ourfali 2015-10-15 09:18:31 EDT
Yevgeny, next time also fill in the whiteboard.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-18 04:21:53 EDT
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-28 06:31:43 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Michael Burman 2015-11-11 07:38:09 EST
Verified on - 3.6.0.3-0.1.el6

Operation Canceled 
Error while executing action: 

silver-vdsb.qa.lab.tlv.redhat.com:
Cannot setup Networks. Following Network Attachments do not exist: 543cca24-7c77-498a-82a3-82273b862288.
Comment 5 Sandro Bonazzola 2015-11-27 02:54:07 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.