Bug 1264979 - poweroff: Failed to execute operation: Access denied
poweroff: Failed to execute operation: Access denied
Status: CLOSED DUPLICATE of bug 1264051
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 15:29 EDT by Dr. David Alan Gilbert
Modified: 2015-09-22 05:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 05:55:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dr. David Alan Gilbert 2015-09-21 15:29:31 EDT
Description of problem:
f22 xfce upgraded to f23
'poweroff' no longer works; I get 'Failed to execute operation: Access denied
Must be root.'


Version-Release number of selected component (if applicable):
systemd-222-4.fc23.x86_64

How reproducible:
75% ?

Steps to Reproduce:
1. poweroff


Actual results:
[dgilbert@dgilbert-t530 ~]$ poweroff
Failed to execute operation: Access denied
Must be root.
[41635.440352] audit: type=1107 audit(1442863575.870:1206): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  denied  { start } for auid=n/a uid=0 gid=0 path="/usr/lib/systemd/system/poweroff.target" cmdline="/usr/lib/systemd/systemd-logind" scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:power_unit_file_t:s0 tclass=service


Expected results:
peace, quiet and a black screen.

Additional info:
Comment 1 Dr. David Alan Gilbert 2015-09-21 15:31:11 EDT
Actually, it's worse than this;
sudo poweroff doesn't help in this case either:

[41864.433658] audit: type=1107 audit(1442863804.802:1224): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  denied  { start } for auid=1000 uid=0 gid=0 path="/usr/lib/systemd/system/poweroff.target" cmdline="poweroff" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=system_u:object_r:power_unit_file_t:s0 tclass=service
                exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'
Failed to start poweroff.target: Access denied

(I'm reasonably sure I've had it work once after I upgraded to f23?!)
Comment 2 Michal Sekletar 2015-09-21 15:53:20 EDT
Can you verify that also selinux-policy is upgraded to version from F23?
Comment 3 Dr. David Alan Gilbert 2015-09-22 05:07:19 EDT
(In reply to Michal Sekletar from comment #2)
> Can you verify that also selinux-policy is upgraded to version from F23?

[dgilbert@dgilbert-t530 ~]$ rpm -qa selinux-policy
selinux-policy-3.13.1-147.fc23.noarch

looks like it.

Dave
Comment 4 Jan Synacek 2015-09-22 05:55:26 EDT
I believe this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1264051. Forced reboot should work around this.

*** This bug has been marked as a duplicate of bug 1264051 ***

Note You need to log in before you can comment on or make changes to this bug.