Bug 1264981 - Storage errors in text mode print markup to console
Storage errors in text mode print markup to console
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-09-21 15:29 EDT by David Shea
Modified: 2015-10-19 10:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 10:48:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text mode storage error (20.84 KB, image/png)
2015-09-21 15:29 EDT, David Shea
no flags Details

  None (edit)
Description David Shea 2015-09-21 15:29:48 EDT
Created attachment 1075580 [details]
text mode storage error

Description of problem:
When a storage error is displayed in text mode, it is displayed as:

There is a problem with your existing storage configuration: <b>problem</b>

The markup shouldn't be there. See attached screenshot.
Comment 1 David Shea 2015-09-21 15:32:34 EDT
The proposed fix is to remove the markup. String freeze exception requested.
Comment 2 Fedora Blocker Bugs Application 2015-09-21 15:33:56 EDT
Proposed as a Freeze Exception for 23-final by Fedora user dshea using the blocker tracking app because:

 It would be nice if the new storage error message didn't have an error in it in text mode.
Comment 3 Adam Williamson 2015-09-28 18:15:01 EDT
Discussed at 2015-09-28 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-28/f23-blocker-review.2015-09-28-16.01.html . This is a cosmetic but easily encountered installer bug and the fix should be isolated, so we grant it a milestone freeze exception.

Please note, however, that so far as the string freeze goes, we are not the droids you're looking for. The string freeze is an entirely separate thing from the milestone freeze (and blocker/freeze exception bug processes). https://fedoraproject.org/wiki/Software_String_Freeze_Policy covers the process for requesting string freeze exceptions; we cannot do that, and this comment does not constitute granting of a string freeze exception.
Comment 4 David Shea 2015-10-19 10:48:27 EDT
The string freeze aspects seem to have stalled, and given how minor the problem is (user with invalid storage sees a little bit of markup in text mode), I don't feel like it's worthwhile to try to get it moving at this point. The issue is fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.