Bug 1265004 - No conductor service registered which supports driver pxe_drac. (HTTP 404)
No conductor service registered which supports driver pxe_drac. (HTTP 404)
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: z5
: 7.0 (Kilo)
Assigned To: Imre Farkas
Toure Dunnon
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 17:07 EDT by wes hayutin
Modified: 2016-09-20 01:03 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-ironic-2015.1.2-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-15 14:04:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2104301 None None None 2016-06-15 01:28 EDT

  None (edit)
Description wes hayutin 2015-09-21 17:07:43 EDT
Description of problem:

 Resource CREATE failed: Error: resources.Controller.resources[2].resources.Controller: Server overcloud-controller-2 delete failed: (500) No valid host was found. Reason: No conductor service registered which supports driver pxe_drac. (HTTP 404)


 Sep 21 15:33:20 host15.beaker.tripleo.lab.eng.rdu2.redhat.com ironic-conductor[72545]: 2015-09-21 15:33:20.773 72545 TRACE oslo_messaging.rpc.dispatcher DracPendingConfigJobExists: Another job with ID JID_428603935169 is already created  to configure BIOS.Setup.1-1. Wait until existing job is completed or is canceled

Not reproducible all the time, good candidate for doc
Comment 1 Ronelle Landy 2015-09-21 17:21:06 EDT
Some additional notes:

The conductor service is up:
[stack@host15 ~]$ systemctl status openstack-ironic-conductor
openstack-ironic-conductor.service - OpenStack Ironic Conductor service
   Loaded: loaded (/usr/lib/systemd/system/openstack-ironic-conductor.service; enabled)
   Active: active (running) since Mon 2015-09-21 15:29:57 EDT; 1h 8min ago
 Main PID: 72545 (ironic-conducto)
   CGroup: /system.slice/openstack-ironic-conductor.service
           └─72545 /usr/bin/python2 /usr/bin/ironic-conductor

Despite the error, pxe_drac is supported:
[stack@host15 ~]$ sudo cat /etc/ironic/ironic.conf | grep pxe_drac
enabled_drivers=pxe_ipmitool,pxe_ssh,pxe_drac

At least one node is shown in error:

[stack@host15 ~]$ nova list
+--------------------------------------+------------------------+--------+------------+-------------+---------------------+
| ID                                   | Name                   | Status | Task State | Power State | Networks            |
+--------------------------------------+------------------------+--------+------------+-------------+---------------------+
| dd923ee8-3aec-4ab5-9086-fe5e4a07b41c | overcloud-compute-0    | ACTIVE | -          | Running     | ctlplane=xx.xx.xx.7 |
| d21d58be-99d6-4d9f-a9cb-8c12bbfba34d | overcloud-controller-0 | ACTIVE | -          | Running     | ctlplane=xx.xx.xx.8 |
| 7cb925f4-0470-4ace-a127-48559c3df4f7 | overcloud-controller-1 | ACTIVE | -          | Running     | ctlplane=xx.xx.xx.9 |
| cea40377-542c-4540-b305-a8a0987205dd | overcloud-controller-2 | ERROR  | -          | Shutdown    |                     |
+--------------------------------------+------------------------+--------+------------+-------------+---------------------+
Comment 2 Imre Farkas 2015-09-22 05:12:48 EDT
The error message "no conductor service registered which supports driver pxe_drac" could be the result of https://bugs.launchpad.net/ironic/+bug/1454492
Comment 10 errata-xmlrpc 2016-06-15 14:04:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1234

Note You need to log in before you can comment on or make changes to this bug.