Bug 1265015 - [RFE] Report what installs new dependencies
[RFE] Report what installs new dependencies
Status: CLOSED DUPLICATE of bug 1213995
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 17:31 EDT by Vít Ondruch
Modified: 2015-09-30 04:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 04:53:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2015-09-21 17:31:14 EDT
Description of problem:

$ LANG=en_US sudo dnf update -x check
Last metadata expiration check performed 0:10:58 ago on Mon Sep 21 23:12:14 2015.
Dependencies resolved.
================================================================================
 Package                     Arch   Version                       Repository
                                                                           Size
================================================================================
Installing:
 compat-libvpx1              x86_64 1.3.0-3.fc24                  rawhide 497 k
 compat-nettle27             x86_64 2.7.1-1.fc24                  rawhide 199 k
 cpp                         x86_64 5.1.1-4.fc23                  rawhide 8.5 M
 gcc                         x86_64 5.1.1-4.fc23                  rawhide  19 M
 gcc-gdb-plugin              x86_64 5.1.1-4.fc23                  rawhide  74 k
 glibc-devel                 x86_64 2.22.90-6.fc24                rawhide 910 k
 glibc-headers               x86_64 2.22.90-6.fc24                rawhide 493 k
 isl                         x86_64 0.14-4.fc23                   rawhide 490 k
 kernel                      x86_64 4.3.0-0.rc1.git4.1.fc24       rawhide  47 k
 kernel-core                 x86_64 4.3.0-0.rc1.git4.1.fc24       rawhide  21 M
 kernel-headers              x86_64 4.3.0-0.rc1.git4.1.fc24       rawhide 1.0 M
 kernel-modules              x86_64 4.3.0-0.rc1.git4.1.fc24       rawhide  18 M
 kernel-modules-extra        x86_64 4.3.0-0.rc1.git4.1.fc24       rawhide 2.3 M
 libmpc                      x86_64 1.0.2-4.fc23                  rawhide  55 k

<snip>

Transaction Summary
================================================================================
Install  14 Packages
Upgrade  94 Packages
Remove    4 Packages



vs



$ LANG=en_US sudo dnf update -x check -x isl
Last metadata expiration check performed 0:12:27 ago on Mon Sep 21 23:12:14 2015.
Dependencies resolved.
================================================================================
 Package                     Arch   Version                       Repository
                                                                           Size
================================================================================
Installing:
 compat-libvpx1              x86_64 1.3.0-3.fc24                  rawhide 497 k
 compat-nettle27             x86_64 2.7.1-1.fc24                  rawhide 199 k
 kernel                      x86_64 4.3.0-0.rc1.git4.1.fc24       rawhide  47 k
 kernel-core                 x86_64 4.3.0-0.rc1.git4.1.fc24       rawhide  21 M
 kernel-modules              x86_64 4.3.0-0.rc1.git4.1.fc24       rawhide  18 M
 kernel-modules-extra        x86_64 4.3.0-0.rc1.git4.1.fc24       rawhide 2.3 M

<snip>

Transaction Summary
================================================================================
Install   6 Packages
Upgrade  94 Packages
Remove    4 Packages


How am I supposed to guess why the additional package are installed? Could you please provide some hint? Neither verbose output is helpful :/



Version-Release number of selected component (if applicable):
$ rpm -q dnf
dnf-1.1.1-2.fc24.noarch


How reproducible:
Always


Steps to Reproduce:
1.
2.
3.

Actual results:
It is not obvious what pulls in additional dependencies.

Expected results:
Output shows what is the reason for installing additional dependencies.

Additional info:
Comment 1 Honza Silhan 2015-09-30 04:53:36 EDT

*** This bug has been marked as a duplicate of bug 1213995 ***

Note You need to log in before you can comment on or make changes to this bug.