This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1265021 - RFE: Add %autosetup macro
RFE: Add %autosetup macro
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm (Show other bugs)
6.7
All Linux
unspecified Severity low
: rc
: ---
Assigned To: packaging-team-maint
Karel Srot
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 18:14 EDT by Orion Poplawski
Modified: 2016-05-10 20:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:54:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
autosetup_macros extracted from /usr/lib/rpm/macros (2.50 KB, text/plain)
2015-12-01 08:44 EST, Ľuboš Kardoš
no flags Details

  None (edit)
Description Orion Poplawski 2015-09-21 18:14:44 EDT
Description of problem:

Any chance the %autosetup macro could be added to the EL6 rpm?  Or should EPEL just add it somewhere else?

Version-Release number of selected component (if applicable):
rpm-4.8.0-47.el6
Comment 2 Ľuboš Kardoš 2015-12-01 08:43:39 EST
Not sure if we want to backport %autosetup to rhel6 rpm. But %autosetup is not hardcoded in rpm, it is implemented by macros. That means you can easily add %autosetup to your system by adding the content of the attached file into your ~/.rpmmacros or create some file in /etc/rpm and put the content there (then it will be available for all users).

Is that acceptable solution for you?
Comment 3 Ľuboš Kardoš 2015-12-01 08:44 EST
Created attachment 1100923 [details]
autosetup_macros extracted from /usr/lib/rpm/macros
Comment 4 Orion Poplawski 2015-12-01 10:47:31 EST
The goal is to allow Fedora/EPEL rpms to share the same spec file.  If it's not going to be added to RHEL's rpm macros, we can add it to epel-release or similar.
Comment 5 Ľuboš Kardoš 2016-01-12 05:03:29 EST
We want to have macros like this in one place. Devel ack for adding autosetup macros into rpm package.
Comment 9 Jason Tibbitts 2016-02-20 00:42:37 EST
I was just CC'd on this.  epel-rpm-macros has autosetup currently, but if it's going into some base RHEL release then we can remove it.  The question is, when should this happen?
Comment 13 errata-xmlrpc 2016-05-10 20:54:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0936.html

Note You need to log in before you can comment on or make changes to this bug.