Bug 1265045 - depends hell
depends hell
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libusb (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 21:42 EDT by Richard Jasmin
Modified: 2015-09-22 03:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 03:31:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Jasmin 2015-09-21 21:42:36 EDT
Description of problem:
libusb is installed ok but requires libusbx.

libusb-devel wants libusbx-devel for some reason but libusbx-devel seems to have a incorrect pgp key and is in chromium repo.The chromium repo key is correct.Although chromium repo is optional and not shipped by default, it cannot be removed do to depends hell.

I dont use chromium or chrome but not so say someone else might.Trying to keep somewhat of a standard spin here.

libusb headers is a common requirement for certain applications and hardware.(maple/arduino/wiimote)

Really dont know where the confusion is because you can at least add in libusb by yourself in debian straight off the net. So which version are we using from the straight source tarball? sources do not require libusbx.

Version-Release number of selected component (if applicable):
detected in 22

How reproducible:
always

Steps to Reproduce:
1.try to install the header devel package.
Comment 1 Hans de Goede 2015-09-22 03:31:37 EDT
libusb in Fedora is libusb-0.1 which is a compatibility wrapper for old packages using the old 0.1 API. libusbx is the version implementing the new 1.x API and is probably what you want.

As for there being a libusbx version in the Chromium repo and that version not having a proper key / other dependency issues, that is not a Fedora problem.

If you're not using Chromium then disable or remove its /etc/yum.repos.d/*.repo file and then do:

dnf distro-sync

to get any packages that repo replaced back to normal.

Note You need to log in before you can comment on or make changes to this bug.