Bug 1265083 - [rhel-7.2] vdsm fails to persist network connections
[rhel-7.2] vdsm fails to persist network connections
Status: CLOSED DUPLICATE of bug 1264667
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.4
Unspecified Unspecified
high Severity high
: ovirt-3.5.6
: 3.5.6
Assigned To: Ido Barkan
Aharon Canan
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 01:42 EDT by Anatoly Litovsky
Modified: 2016-02-10 14:15 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 07:57:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport with all logs (5.13 MB, application/x-xz)
2015-09-22 03:48 EDT, Anatoly Litovsky
no flags Details

  None (edit)
Description Anatoly Litovsky 2015-09-22 01:42:04 EDT
Description of problem:
after install RHEVH 7.2 vdsm fails to persist network connections
as seen in the attached ovirt-node.log
that in turn fails the vdsm-reg action.
Comment 1 Dan Kenigsberg 2015-09-22 03:29:16 EDT
(In reply to Anatoly Litovsky from comment #0)
> as seen in the attached ovirt-node.log

attachment forgotten?
Comment 2 Anatoly Litovsky 2015-09-22 03:48 EDT
Created attachment 1075676 [details]
sosreport with all logs
Comment 3 Ido Barkan 2015-09-24 06:34:02 EDT
seems related to bug 1264667.

see /var/log/upgrade.log

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/vdsm/tool/upgrade.py", line 93, in apply_upgrade
  File "/usr/lib/python2.7/site-packages/vdsm/tool/unified_persistence.py", line 192, in run
  File "/usr/lib/python2.7/site-packages/vdsm/tool/unified_persistence.py", line 43, in run
  File "/usr/lib/python2.7/site-packages/vdsm/tool/unified_persistence.py", line 129, in _getNetInfo
  File "/usr/lib/python2.7/site-packages/vdsm/netinfo.py", line 835, in __init__
  File "/usr/lib/python2.7/site-packages/vdsm/netinfo.py", line 738, in get
  File "/usr/lib/python2.7/site-packages/vdsm/netinfo.py", line 403, in getRoutes
  File "/usr/lib/python2.7/site-packages/vdsm/ipwrapper.py", line 510, in routeShowAllDefaultGateways
  File "/usr/lib/python2.7/site-packages/vdsm/ipwrapper.py", line 506, in routeShowGateways
  File "/usr/lib/python2.7/site-packages/vdsm/ipwrapper.py", line 490, in _execCmd
  File "/usr/lib/python2.7/site-packages/vdsm/utils.py", line 742, in execCmd
  File "/usr/lib64/python2.7/site-packages/cpopen/__init__.py", line 51, in __init__
  File "/usr/lib64/python2.7/subprocess.py", line 712, in __init__
TypeError: _execute_child_v276() got an unexpected keyword argument 'restore_sigpipe'
Comment 4 Fabian Deutsch 2015-09-24 07:57:40 EDT

*** This bug has been marked as a duplicate of bug 1264667 ***

Note You need to log in before you can comment on or make changes to this bug.