Bug 1265112 - Can't access django quickstart with python-3.3/python2.7
Can't access django quickstart with python-3.3/python2.7
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Timothy Williams
XiuJuan Wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 03:27 EDT by XiuJuan Wang
Modified: 2015-11-05 10:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 10:26:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description XiuJuan Wang 2015-09-22 03:27:35 EDT
Description of problem:
When access django33, met ‘The requested URL / was not found on this server.’ 404 error.

Version-Release number of selected component (if applicable):
INT(devenv-5642)

How reproducible:
always

Steps to Reproduce:
1.Create django33 quickstart
rhc app create django33 python-3.3 --from-code=https://github.com/openshift/django-example  
2.Access app.

3.

Actual results:
# curl http://django33-xiuwang.int.rhcloud.com/ 
<h1>Not Found</h1><p>The requested URL / was not found on this server.</p>

Expected results:
Could access django33 app.

Additional info:
Comment 1 Vu Dinh 2015-10-22 16:18:41 EDT
Tested on the INT 5674 and the bug appears to be fixed already.
Comment 2 XiuJuan Wang 2015-10-27 05:45:54 EDT
Test in STG(devenv-stage_1188)and INT, still could reproduce this bug.
Are you using this quickstart https://github.com/openshift/django-example?
Comment 3 Vu Dinh 2015-11-05 10:23:09 EST
Hi,

I have just verified with the owner of django-example repo and confirmed that this is not a bug. The django-example repo is an empty one which means it only has an empty Django application and it will not show anything when you access the URL of the application as it doesn't have any html files. This is intentional as you have to create your own application (as go through the Django tutorial). However, if you go through the create user account step on the read me file, the /admin is functional as it's the only thing accessible when an empty application is created.

Note You need to log in before you can comment on or make changes to this bug.