Bug 1265142 - tests failing
tests failing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python-Fiona (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1245382
  Show dependency treegraph
 
Reported: 2015-09-22 04:23 EDT by Peter Robinson
Modified: 2015-11-04 07:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 07:56:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failing tests output (158.17 KB, text/plain)
2015-09-22 04:23 EDT, Peter Robinson
no flags Details

  None (edit)
Description Peter Robinson 2015-09-22 04:23:20 EDT
Created attachment 1075716 [details]
failing tests output

Tests are failing on 1.6.x on Fedora 23+. Attached output of failing make check

http://koji.fedoraproject.org/koji/taskinfo?taskID=11174575
Comment 1 Miro Hrončok 2015-09-22 04:27:53 EDT
I'm aware of this. It's because Fedora 23+ now has GDAL 2. See upstream's https://github.com/Toblerity/Fiona/issues/239
Comment 2 Miro Hrončok 2015-09-22 07:23:20 EDT
Please revert your commit. Disabling tests just to make the package build does not fix this. Fiona does not work correctly with GDAL 2. That's why the tests are failing.

Please never ever touch my packages again without previous knowledge about what's going on. Thank you.
Comment 3 Peter Robinson 2015-09-22 13:04:00 EDT
If you don't have it fixed in one way or another you're package will be automatically blocked and dropped from F-23+. This buys you time to sort it out. 

Frankly I don't give a damn either way, I'm just buying you time so you don't have to go through a re-review process while you sort out the problems.
Comment 4 Miro Hrončok 2015-09-23 11:34:21 EDT
If I would like to do that, I'd do that myself. If you wish to hep me, talk to me and we can sort things out. Disabling tests because they are failing is not a fix and if you have asked for permission, I wouldn't give it to you.

Please revert your commit.
Comment 5 Miro Hrončok 2015-09-23 11:34:35 EDT
s/hep/help/
Comment 6 Fedora Admin XMLRPC Client 2015-09-29 11:11:19 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Peter Robinson 2015-11-04 07:56:03 EST
retired in f23+

Note You need to log in before you can comment on or make changes to this bug.