This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1265148 - Dist-geo-rep: Support geo-replication to work with sharding
Dist-geo-rep: Support geo-replication to work with sharding
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Kotresh HR
:
Depends On:
Blocks: 1275972 1284453 1313352
  Show dependency treegraph
 
Reported: 2015-09-22 04:36 EDT by Kotresh HR
Modified: 2016-06-16 09:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1275972 1284453 1313352 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:37:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kotresh HR 2015-09-22 04:36:17 EDT
Description of problem:
This bug tracks all the changes required for geo-replication to work with
sharding.

Requirements as per design:
  1. Both master and slave should be sharded
  2. Sharding configurations should be retained same as in master

Version-Release number of selected component (if applicable):
mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Geo-replication does not work with sharding

Expected results:
Geo-replication should work with sharding.

Additional info:
Comment 1 Vijay Bellur 2015-10-13 08:04:28 EDT
REVIEW: http://review.gluster.org/12228 (features/shard: Support geo-rep for sharded volume) posted (#5) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 2 Vijay Bellur 2015-10-26 08:57:51 EDT
COMMIT: http://review.gluster.org/12228 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 8216ecb871c8d74edcc46b7f13d1e1879be25de1
Author: Kotresh HR <khiremat@redhat.com>
Date:   Thu Sep 24 15:42:14 2015 +0530

    features/shard: Support geo-rep for sharded volume
    
    Approach:
          Shard xlator on slave side is by passed for all the fops
    to geo-rep mount. So each shard on master is considered as a
    separate file for geo-rep and it syncs them separately on to
    slave. The extended attribute in which shard maintains the
    size is also synced from master and shard on slave doesn't
    calculate by itself.
    
    Pre-requisites:
          1. If master is sharded volume, slave also should be sharded.
          2. Slave's shard configurations should be same as master.
          3. Geo-rep config of xattr sync should not be disabled.
    
    All other dependant patches:
          1. http://review.gluster.org/#/c/12205/
          2. http://review.gluster.org/#/c/12206/
          3. http://review.gluster.org/#/c/12225/
          4. http://review.gluster.org/#/c/12226/
    
    Change-Id: I474220d69fa030b1e06a4fa0868c34fabe02efcf
    BUG: 1265148
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/12228
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 3 Vijay Bellur 2015-10-27 04:38:28 EDT
REVIEW: http://review.gluster.org/12226 (geo-rep: Handle FXATTROP and XATTROP) posted (#5) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 4 Vijay Bellur 2015-10-27 05:24:32 EDT
REVIEW: http://review.gluster.org/12205 (geo-rep: Fix syncing chown in xsync crawl) posted (#3) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 5 Vijay Bellur 2015-10-28 00:52:48 EDT
REVIEW: http://review.gluster.org/12226 (geo-rep: Handle FXATTROP and XATTROP) posted (#6) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 6 Vijay Bellur 2015-11-23 01:49:19 EST
COMMIT: http://review.gluster.org/12225 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 8805a4c65bf9c725cb26bb6979f3ebd62748138f
Author: Kotresh HR <khiremat@redhat.com>
Date:   Tue Sep 22 16:18:29 2015 +0530

    features/changelog: Capture FXATTROP and XATTROP in changelog
    
    GEO-REP INTEROP WITH SHARD FEATURE
    
    shard xlator updates size of the file using FXATTROP
    or XATTROP. Hence record the same in changelog.
    
    Change-Id: Ie0c21e9326da05ea78dc1ef3fd32a90ef38b4bb9
    BUG: 1265148
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/12225
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 7 Niels de Vos 2016-06-16 09:37:36 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.