Bug 1265165 - 'Name can't be blank' error under parameter tab, on creating a hostgroup with activation-key
Summary: 'Name can't be blank' error under parameter tab, on creating a hostgroup with...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-22 09:25 UTC by Sachin Ghai
Modified: 2019-09-25 20:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:19:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
Name can't be blank error under parameter tab, on creating a hostgroup with activation-key (39.58 KB, image/png)
2015-09-22 09:25 UTC, Sachin Ghai
no flags Details
foreman-debug (347.20 KB, application/x-xz)
2015-09-22 09:31 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 11928 None None None 2016-04-22 15:57:43 UTC

Description Sachin Ghai 2015-09-22 09:25:13 UTC
Created attachment 1075749 [details]
Name can't be blank error under parameter tab, on creating a hostgroup with activation-key

Description of problem:
I was trying to create a hostgroup and associated activation_key. But when I submitted the form, UI raises error under 'Parameters' tab. Name can't be blank. I believe activation_key param should auto set.

production.log:

 | Started POST "/hostgroups" for 10.65.193.85 at 2015-09-22 14:44:00 +0530
2015-09-22 14:44:00 [app] [I] Processing by HostgroupsController#create as */*
2015-09-22 14:44:00 [app] [I]   Parameters: {"utf8"=>"✓", "authenticity_token"=>"0hvMpUAmzZlcOWpOJrzmHtdu+y5pHK8CQ47zgU4F13c=", "hostgroup"=>{"name"=>"sgroup", "lifecycle_environment_id"=>"2", "content_view_id"=>"2", "environment_id"=>"", "content_source_id"=>"1", "puppet_ca_proxy_id"=>"1", "puppet_proxy_id"=>"1", "domain_id"=>"1", "subnet_id"=>"1", "realm_id"=>"", "architecture_id"=>"1", "operatingsystem_id"=>"2", "medium_id"=>"8", "root_pass"=>"[FILTERED]", "group_parameters_attributes"=>{"0"=>{"name"=>"", "value"=>"[FILTERED]", "hidden_value"=>"[FILTERED]", "_destroy"=>"false"}, "1442913240618"=>{"name"=>"", "value"=>"[FILTERED]", "hidden_value"=>"[FILTERED]", "_destroy"=>"false"}}, "location_ids"=>["", "2"], "organization_ids"=>["", "1"], "id"=>""}, "kt_activation_keys"=>"rhel67_ak"}
2015-09-22 14:44:00 [app] [I] Failed to save: Name can't be blank, Group parameters Please ensure the following parameters name are unique
2015-09-22 14:44:01 [app] [I]   Rendered common/os_selection/_architecture.html.erb (5.8ms)
2015-09-22 14:44:01 [app] [I]   Rendered common/os_selection/_operatingsystem.html.erb (38.7ms)
2015-09-22 14:44:01 [app] [I]   Rendered common/os_selection/_initial.html.erb (51.6ms)
2015-09-22 14:44:01 [app] [I]   Rendered puppetclasses/_class_parameters.html.erb (0.0ms)
2015-09-22 14:44:01 [app] [I]   Rendered puppetclasses/_classes_parameters.html.erb (18.6ms)
2015-09-22 14:44:01 [app] [I]   Rendered common_parameters/_puppetclass_parameter.html.erb (5.9ms)
2015-09-22 14:44:01 [app] [I]   Rendered common_parameters/_puppetclasses_parameters.html.erb (9.0ms)
2015-09-22 14:44:01 [app] [I]   Rendered common_parameters/_parameter.html.erb (3.7ms)
2015-09-22 14:44:01 [app] [I]   Rendered common_parameters/_parameter.html.erb (3.2ms)
2015-09-22 14:44:01 [app] [I]   Rendered common_parameters/_parameter.html.erb (2.7ms)
2015-09-22 14:44:01 [app] [I]   Rendered common_parameters/_parameters.html.erb (13.8ms)
2015-09-22 14:44:01 [app] [I]   Rendered taxonomies/_loc_org_tabs.html.erb (16.3ms)
2015-09-22 14:44:01 [app] [I]   Rendered hostgroups/_form.html.erb (237.8ms)
2015-09-22 14:44:01 [app] [I]   Rendered hostgroups/new.html.erb within layouts/application (238.9ms)
2015-09-22 14:44:01 [app] [I]   Rendered home/_user_dropdown.html.erb (4.3ms)
2015-09-22 14:44:01 [app] [I] Read fragment views/tabs_and_title_records-3 (0.4ms)
2015-09-22 14:44:01 [app] [I]   Rendered home/_topbar.html.erb (7.2ms)
2015-09-22 14:44:01 [app] [I]   Rendered layouts/base.html.erb (9.7ms)
2015-09-22 14:44:01 [app] [I] Completed 200 OK in 387ms (Views: 225.4ms | ActiveRecord: 48.6ms)


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Create a CV/activation-key
2. Create a hostgroup
3. Associate activation-key
4. submit form

Actual results:
2015-09-22 14:44:00 [app] [I] Failed to save: Name can't be blank, Group parameters Please ensure the following parameters name are unique

Why this a info [I] type message. shouldn't be an error ?

Expected results:
activation-key param should auto set and form should be submitted successfuly

Additional info:

Comment 1 Sachin Ghai 2015-09-22 09:31:56 UTC
Created attachment 1075754 [details]
foreman-debug

Comment 2 Sachin Ghai 2015-09-22 09:36:28 UTC
reproducible in:

foreman-1.10.0-0.develop.201509180916git04fa19d.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.3.0-2.201509101340gitff06fcb.el7.noarch
foreman-release-1.10.0-0.develop.201509180916git04fa19d.el7.noarch
katello-installer-base-2.4.0-1.nightly.201509040043gitb37b92b.el7.noarch
katello-server-ca-1.0-1.noarch
katello-installer-2.4.0-1.nightly.201509040043gitb37b92b.el7.noarch
katello-service-2.4.0-6.nightly.el7.noarch
katello-2.4.0-6.nightly.el7.noarch

Comment 5 Christine Fouant 2015-09-22 20:51:33 UTC
Created redmine issue http://projects.theforeman.org/issues/11928 from this bug

Comment 6 Bryan Kearney 2015-09-22 22:03:58 UTC
Upstream bug component is Content Management

Comment 7 Bryan Kearney 2015-10-07 16:04:33 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11928 has been closed
-------------
Christine Fouant
Applied in changeset commit:katello|77f3fc91f3427dc4e6db69df941ade76a25eefcf.

Comment 8 Tazim Kolhar 2015-11-16 13:26:56 UTC
VERIFIED:
# rpm -qa | grep foreman
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-release-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-ovirt-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-libvirt-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-postgresql-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-debug-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-proxy-1.11.0-0.develop.201511111339git7cbe47a.el7.noarch
foreman-compute-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201511111650gitdda13df.el7.noarch
foreman-gce-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-vmware-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch

steps:
1. Create a CV/activation-key
2. Create a hostgroup
3. Associate activation-key
4. submit form

No error occurred. Form submitted successfully

Comment 9 Mario Gamboa 2015-11-19 01:43:56 UTC
When is going to be ready the patch

Comment 13 errata-xmlrpc 2016-07-27 09:19:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.