Bug 1265171 - RHN page crash after auto-install with rhn registration
RHN page crash after auto-install with rhn registration
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.5
Unspecified Unspecified
high Severity high
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Ryan Barry
wanghui
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 05:53 EDT by wanghui
Modified: 2016-03-09 09:39 EST (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-3.3.0-0.13.20151008git03eefb5.el7ev.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:39:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log files (108.44 KB, application/x-gzip)
2015-09-22 05:53 EDT, wanghui
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46537 None None None Never

  None (edit)
Description wanghui 2015-09-22 05:53:01 EDT
Created attachment 1075755 [details]
/var/log files

Description of problem:
RHN page crash after auto-install with rhn registration succeed.

Version-Release number of selected component (if applicable):
rhev-hypervisor-6-6.7-20150917.0.el7ev
ovirt-node-3.2.3-23.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Auto clean install with the follow parameters.
BOOTIF=eth3 storage_init=/dev/sda rhn_username=***** rhn_password=***** adminpw=4DHc2Jl0D05xk firstboot  
2. Login rhevh and change to RHN page

Actual results:
1. After step2, RHN page crash and report error like follows.

An error appeared in the UI: TypeError("argument of type 'NoneType' is not iterable",)
Press ENTER to logout ...
or enter 's' to drop to shell

Expected results:
1.After step2, it can enter the RHN page.

Additional info:
Comment 1 wanghui 2015-10-26 05:16:02 EDT
Test Version:
rhev-hypervisor7-7.2-20151025.0.el7ev
ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch

Test steps:
1. Auto clean install with the follow parameters.
BOOTIF=em1 storage_init=/dev/sda rhn_username=***** rhn_password=***** adminpw=4DHc2Jl0D05xk firstboot  
2. Login rhevh and change to RHN page

Test result:
1. RHN page shows "RHN" as the registration status.

So this issue is fixed in ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch now. Change the status to Verified.
Comment 3 errata-xmlrpc 2016-03-09 09:39:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.