Bug 1265175 - Miss the verify the BOOTIF device during auto-installation
Miss the verify the BOOTIF device during auto-installation
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.5
Unspecified Unspecified
medium Severity high
: ovirt-3.6.1
: 3.6.0
Assigned To: Fabian Deutsch
wanghui
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 06:01 EDT by wanghui
Modified: 2016-02-10 14:17 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 04:35:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47524 master MERGED auto-install: Raise error if NIC does not exist Never
oVirt gerrit 47536 ovirt-3.6 MERGED auto-install: Raise error if NIC does not exist Never

  None (edit)
Description wanghui 2015-09-22 06:01:11 EDT
Description of problem:
It lacked of verification the BOOTIF device during auto-installation. It can pass the network setup process with the wrong BOOTIF device. This will make network related service failed which will cause auto-install failed anyway.

Version-Release number of selected component (if applicable):
rhev-hypervisor-6-6.7-20150917.0.e17ev
ovirt-node-3.2.3-20.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Auto clean install with the follow parameters.
BOOTIF=em2 storage_init=/dev/sda adminpw=4DHc2Jl0D05xk firstboot  
2. Login rhevh and check network

Actual results:
1. After step2, there is no em2 actually. 

Expected results:
1. It should report no such BOOTIF device during the auto-installation.

Additional info:
Comment 1 wanghui 2015-11-26 00:17:06 EST
Test version:
rhev-hypervisor7-7.2-20151112.1.el7ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

Test steps:
1. Auto clean install with the follow parameters.
BOOTIF=em2 storage_init=/dev/sda adminpw=4DHc2Jl0D05xk firstboot  


Test result:
1. The installation process ended with dracut mode which has no prompt about the nic is not exists.

According to the fix path, it should raise the error that the NIC is not exist.

So this issue is not fixed in ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
.
Comment 2 Fabian Deutsch 2015-11-26 04:35:21 EST
This bug was originally reported on el6, it seems that on el7 this bug can not appear, because dracut is alreading checking if the nic can be brought up or not.

node can not do anything to check the NIC, because dracut already fails very early during boot.

If we want a better error if an unknown nic is used, then this must be filed against dracut.

Closing this bug for now, because it is no bug in the node code base anymore.

Note You need to log in before you can comment on or make changes to this bug.