Bug 1265177 - regression for EL7: spmprotect always reboot when fencing vdsm on systemd
regression for EL7: spmprotect always reboot when fencing vdsm on systemd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.0
Unspecified Unspecified
high Severity high
: ovirt-3.5.6
: 3.5.6
Assigned To: Nir Soffer
Aharon Canan
storage
: Regression, ZStream
Depends On: 1222564
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 06:09 EDT by rhev-integ
Modified: 2016-02-10 14:21 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When VDSM was ported to systemd for Red Hat Enterprise Linux 7, it stopped generating its pid file which was required for safelease. As a result, when safelease failed to maintain the SPM lease, VDSM didn't get terminated cleanly and rebooted the SPM host, killing virtual machines running on the host. With this update, VDSM passes its pid to safelease via a command line parameter. If safelease fails to maintain the SPM lease, VDSM is terminated in a clean way without rebooting the machine, and the SPM role is assigned to another host without effecting virtual machines running on the SPM host.
Story Points: ---
Clone Of: 1222564
Environment:
Last Closed: 2015-12-01 15:40:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45963 master MERGED safelease: Unbreak safelease on systemd Never
oVirt gerrit 46057 master MERGED safelease: Increase spmprotect timeouts Never
oVirt gerrit 46331 ovirt-3.6 MERGED safelease: Unbreak safelease on systemd Never
oVirt gerrit 46332 ovirt-3.6 MERGED safelease: Increase spmprotect timeouts Never
oVirt gerrit 46484 ovirt-3.5 MERGED safelease: Unbreak safelease on systemd Never
oVirt gerrit 46485 ovirt-3.5 MERGED safelease: Increase spmprotect timeouts Never

  None (edit)
Comment 3 Aharon Canan 2015-11-05 09:13:08 EST
verified using vt18.2

1. create data center v 3.0
2. create cluster v 3.4
3. add host
4. create storage domain v1
5. wait until spm is up
6. check now maintenance/activation (no regression)
7. block access to storage
8. watch vdsm being killed without reboot (previously host would reboot after this)
9. unblock access to storage
10. watch vdsm become spm again (no regression)

tested V1 nfs domain and V2 block domain (can't set v1 block domain).
Comment 6 Julie 2015-11-12 02:19:10 EST
cool, thanks for the clarification!
Comment 8 errata-xmlrpc 2015-12-01 15:40:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2530.html

Note You need to log in before you can comment on or make changes to this bug.