Bug 1265180 - Error validating value u'baremetal': The Flavor ID (baremetal) could not be found
Error validating value u'baremetal': The Flavor ID (baremetal) could not be f...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ga
: 8.0 (Liberty)
Assigned To: Dmitry Tantsur
Marius Cornea
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 06:37 EDT by Marius Cornea
Modified: 2016-05-16 03:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The director requires the 'baremetal' flavor, even if unused. Without this flavor, the deployment fails with an error. Now the Undercloud installation automatically creates the 'baremetal' flavor. With the flavor in place, the director does not report the error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:39:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-09-22 06:37:23 EDT
Description of problem:
I'm trying to deploying using Heat templates and manual nodes tagging but it looks that I need to add the baremetal flavor even if I'm not using it.

Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.10-5.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. openstack overcloud deploy --templates ~/templates/my-overcloud -e ~/templates/my-overcloud/environments/network-isolation.yaml -e ~/templates/network-environment.yaml --control-scale 1 --compute-scale 1 --swift-storage-scale 1 --control-flavor control --compute-flavor compute --swift-storage-flavor storage --ntp-server clock.redhat.com -e ~/templates/snmpd.yaml

Actual results:
ERROR: openstack ERROR: Parameter 'OvercloudCephStorageFlavor' is invalid: Error validating value u'baremetal': The Flavor ID (baremetal) could not be found.


Expected results:
Deployment would proceed as the deployed nodes are not using the baremetal flavor.

Additional info:
Workaround is to create the baremetal flavor.
Comment 2 chris alfonso 2015-09-22 12:04:47 EDT
We can probably add validation to check that any flavors needed by the deployment exist.
Comment 4 Brad P. Crochet 2016-02-08 07:46:05 EST
The undercloud install now creates a number of flavors by default, including the baremetal flavor. This should no longer be an issue.
Comment 6 Dmitry Tantsur 2016-03-29 08:02:54 EDT
The baremetal flavor is there by default now:

[stack@instack ~]$ openstack flavor list | grep baremetal
| a3862ee6-c59b-48af-8c7b-ab7bce484c1f | baremetal     | 4096 |   40 |         0 |     1 | True      |

I also do not see the error mentioned in the report.
Comment 8 errata-xmlrpc 2016-04-07 17:39:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.