Bug 1265220 - pam_yubico-2.21 is available
pam_yubico-2.21 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pam_yubico (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nick Bebout
Fedora Extras Quality Assurance
: FutureFeature, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 08:16 EDT by Upstream Release Monitoring
Modified: 2016-05-13 02:26 EDT (History)
5 users (show)

See Also:
Fixed In Version: pam_yubico-2.21-2.fc24 pam_yubico-2.21-3.fc23 pam_yubico-2.21-3.el6 pam_yubico-2.21-3.fc22 pam_yubico-2.21-3.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 16:54:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 2.21 (#1265220) (1.03 KB, patch)
2016-02-19 07:18 EST, Upstream Release Monitoring
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2015-09-22 08:16:35 EDT
Latest upstream release: 2.20
Current version/release in rawhide: 2.19-1.fc23
URL: https://github.com/Yubico/yubico-pam

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-09-22 08:16:49 EDT
Failed to kick off scratch build.

cmd:  sha256sum /var/tmp/thn-VTB0Cz/100.0%
return code:  1
stdout:

stderr:
sha256sum: /var/tmp/thn-VTB0Cz/100.0%: No such file or directory
Comment 2 Upstream Release Monitoring 2015-11-18 11:14:44 EST
nb's pam_yubico-2.20-1.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=700101
Comment 3 Upstream Release Monitoring 2016-02-04 12:40:46 EST
releng's pam_yubico-2.20-2.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=725068
Comment 4 Upstream Release Monitoring 2016-02-19 07:18:09 EST
Latest upstream release: 2.21
Current version/release in rawhide: 2.20-2.fc24
URL: https://github.com/Yubico/yubico-pam

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 5 Upstream Release Monitoring 2016-02-19 07:18:27 EST
Created attachment 1128543 [details]
[patch] Update to 2.21 (#1265220)
Comment 6 Upstream Release Monitoring 2016-02-19 07:23:51 EST
Scratch build completed http://koji.fedoraproject.org/koji/taskinfo?taskID=13047807
Comment 7 Upstream Release Monitoring 2016-02-23 04:33:43 EST
ohaessler's pam_yubico-2.21-1.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=738210
Comment 8 Fedora Update System 2016-02-23 05:13:37 EST
pam_yubico-2.21-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-1ebfbf317c
Comment 9 Fedora Update System 2016-02-23 05:13:37 EST
pam_yubico-2.21-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cdcd67be0d
Comment 10 Fedora Update System 2016-02-23 05:13:45 EST
pam_yubico-2.21-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0bff277a42
Comment 11 Fedora Update System 2016-02-23 16:26:23 EST
pam_yubico-2.21-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0bff277a42
Comment 12 Fedora Update System 2016-02-24 13:23:25 EST
pam_yubico-2.21-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-1ebfbf317c
Comment 13 Fedora Update System 2016-02-24 16:51:32 EST
pam_yubico-2.21-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cdcd67be0d
Comment 14 Gerald Cox 2016-02-28 09:49:34 EST
Provided negative karma... does not work.  Receive the following error:
 adding faulty module: /usr/lib64/security/pam_yubico.so: 17 Time(s)
     unable to dlopen(/usr/lib64/security/pam_yubico.so): /usr/lib64/security/pam_yubico.so: undefined symbol: ykclient_set_proxy: 17 Time(s)

This change also requires update to ykclient to 2.15, which hasn't been done.
Comment 15 Fedora Update System 2016-05-03 11:07:57 EDT
ykclient-2.15-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e325023378
Comment 16 Fedora Update System 2016-05-03 11:08:09 EDT
ykclient-2.15-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-312c11093d
Comment 17 Fedora Update System 2016-05-03 11:09:22 EDT
ykclient-2.15-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0361bf0584
Comment 18 Fedora Update System 2016-05-03 11:09:30 EDT
ykclient-2.15-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d86f935840
Comment 19 Fedora Update System 2016-05-03 11:09:38 EDT
ykclient-2.15-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6faedf8dbc
Comment 20 Upstream Release Monitoring 2016-05-03 11:27:59 EDT
nb's pam_yubico-2.21-2.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=759803
Comment 21 Fedora Update System 2016-05-04 02:52:56 EDT
pam_yubico-2.21-2.fc22, ykclient-2.15-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0361bf0584
Comment 22 Fedora Update System 2016-05-04 03:25:16 EDT
pam_yubico-2.21-2.fc23, ykclient-2.15-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6faedf8dbc
Comment 23 Fedora Update System 2016-05-04 06:51:28 EDT
pam_yubico-2.21-2.el6, ykclient-2.15-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-312c11093d
Comment 24 Fedora Update System 2016-05-04 07:20:06 EDT
pam_yubico-2.21-2.el7, ykclient-2.15-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e325023378
Comment 25 Fedora Update System 2016-05-04 10:29:46 EDT
pam_yubico-2.21-2.fc24, ykclient-2.15-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d86f935840
Comment 26 Gerald Cox 2016-05-04 20:27:09 EDT
Spec file incorrectly specifies:  
Requires:       ykclient > 2.15

This statement should be removed.  It is not needed because you already have:
BuildRequires:  ykclient-devel >= 2.15

Requires:  Is only used when the dependency is required at run time but NOT at build time.  Since ykclient is required for the build, you shouldn't specify Requires. 

It only adds additional unneeded complexity to the Spec file and introduces the chance for errors (such as this one).
Comment 27 Fedora Update System 2016-05-10 07:48:42 EDT
pam_yubico-2.21-2.fc24, ykclient-2.15-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2016-05-10 12:54:09 EDT
pam_yubico-2.21-3.el6 ykclient-2.15-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-312c11093d
Comment 29 Fedora Update System 2016-05-10 12:55:21 EDT
pam_yubico-2.21-3.el7 ykclient-2.15-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e325023378
Comment 30 Fedora Update System 2016-05-10 12:57:18 EDT
pam_yubico-2.21-3.fc23 ykclient-2.15-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6faedf8dbc
Comment 31 Fedora Update System 2016-05-10 12:59:17 EDT
pam_yubico-2.21-3.fc22 ykclient-2.15-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0361bf0584
Comment 32 Fedora Update System 2016-05-12 03:53:20 EDT
pam_yubico-2.21-3.el6, ykclient-2.15-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-312c11093d
Comment 33 Fedora Update System 2016-05-12 04:35:55 EDT
pam_yubico-2.21-3.el7, ykclient-2.15-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e325023378
Comment 34 Fedora Update System 2016-05-12 05:26:15 EDT
pam_yubico-2.21-3.fc22, ykclient-2.15-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0361bf0584
Comment 35 Fedora Update System 2016-05-12 05:36:52 EDT
pam_yubico-2.21-3.fc23, ykclient-2.15-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6faedf8dbc
Comment 36 Fedora Update System 2016-05-12 16:54:01 EDT
pam_yubico-2.21-3.fc23, ykclient-2.15-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 37 Fedora Update System 2016-05-13 02:06:42 EDT
pam_yubico-2.21-3.el6, ykclient-2.15-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.
Comment 38 Fedora Update System 2016-05-13 02:21:19 EDT
pam_yubico-2.21-3.fc22, ykclient-2.15-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 39 Fedora Update System 2016-05-13 02:26:43 EDT
pam_yubico-2.21-3.el7, ykclient-2.15-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.