Bug 1265231 - Translation and User's profile picture not applied
Translation and User's profile picture not applied
Status: CLOSED DUPLICATE of bug 1270747
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 08:33 EDT by Samuel Lee
Modified: 2016-03-11 21:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 21:17:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Login screen in English (1.31 MB, image/jpeg)
2015-09-22 08:33 EDT, Samuel Lee
no flags Details

  None (edit)
Description Samuel Lee 2015-09-22 08:33:26 EDT
Created attachment 1075800 [details]
Login screen in English

Description of problem:


Localization of the default login screen is ignored (And hence Login screen is in English) despite the default system locale is set as Chinese Simplified (PRC). It happens to other systems with other languages than English. The user's profile picture is not applied during initial login as well.

I am using KDE version of Fedora 22 from ISO.


Version-Release number of selected component (if applicable): 0.10.0-4.fc22


How reproducible: Everytime.


Steps to Reproduce:

First 3 steps is to install a Fedora and configure its default locale to be anything than English.

1. Nothing, just install Fedora 22 KDE spinoff:
https://spins.fedoraproject.org/kde/download/index.html

2. Install all Chinese Simplified (Or any other languages for that matter) for KDE.


3. Go to "Settings" -> "Languages" from the 'Start Menu'. It allows selection of default language.

4. Go to "User Accounts" and set a profile picture. I choose a selfie picture as my user account picture.

Reproducible everytime:

4. Reboot, and let the system goes to login screen.

Actual results:

Regardless of system's default locale, login screen is always in English. The user profile picture is a generic picture instead of a selfie picture.


Expected results:

Login screen's language should match with admin / root user's default language.

Additional info:

1: A screenshot is given. It had happened for many months.

2: Whenever I locked a screen, this issue does not apply. Selfie picture and my system's locale were displayed correctly. Only log off or reboot will give me this problem.
Comment 1 Rex Dieter 2016-03-11 21:17:31 EST
default $HOME permissions do not allow sddm to read $HOME/.face.icon

if you do:

chmod a+x $HOME

then it should work.

*** This bug has been marked as a duplicate of bug 1270747 ***

Note You need to log in before you can comment on or make changes to this bug.