Bug 1265261 - Attribute error in error log is reported on the first access of IdP page
Attribute error in error log is reported on the first access of IdP page
Status: CLOSED DUPLICATE of bug 1256518
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipsilon (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 09:37 EDT by Veronika Kabatova
Modified: 2015-09-22 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 12:32:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Veronika Kabatova 2015-09-22 09:37:49 EDT
Description of problem:
With the first access to http://`hostname`/idp on ipsilon server, the Apache error log shows traceback:

[Tue Sep 22 06:46:30.730404 2015] [:error] [pid 26847] Exception in thread Thread-3:
[Tue Sep 22 06:46:30.730439 2015] [:error] [pid 26847] Traceback (most recent call last):
[Tue Sep 22 06:46:30.730441 2015] [:error] [pid 26847]   File "/usr/lib64/python2.7/threading.py", line 811, in __bootstrap_inner
[Tue Sep 22 06:46:30.730443 2015] [:error] [pid 26847]     self.run()
[Tue Sep 22 06:46:30.730444 2015] [:error] [pid 26847]   File "/usr/lib/python2.7/site-packages/cherrypy/process/plugins.py", line 475, in run
[Tue Sep 22 06:46:30.730446 2015] [:error] [pid 26847]     self.function(*self.args, **self.kwargs)
[Tue Sep 22 06:46:30.730448 2015] [:error] [pid 26847]   File "/usr/lib/python2.7/site-packages/ipsilon/util/data.py", line 343, in _maybe_run_cleanup
[Tue Sep 22 06:46:30.730450 2015] [:error] [pid 26847]     removed_entries = self._cleanup()
[Tue Sep 22 06:46:30.730451 2015] [:error] [pid 26847]   File "/usr/lib/python2.7/site-packages/ipsilon/util/data.py", line 603, in _cleanup
[Tue Sep 22 06:46:30.730452 2015] [:error] [pid 26847]     table = SqlQuery(self._db, self.table, UNIQUE_DATA_TABLE)._table
[Tue Sep 22 06:46:30.730460 2015] [:error] [pid 26847] AttributeError: 'TranStore' object has no attribute 'table'

ipsilon works as expected, I was able to reproduce it issue on several machines, but it always happened only on the first access.


Version-Release number of selected component (if applicable):
ipsilon-1.0.0-10

How reproducible:
Always

Steps to Reproduce:
1. ipsilon-server-install --form yes
2. service httpd restart
3. access the http://`hostname`/idp page

Actual results:
Apache error log fills up with AttributeError traceback

Expected results:
No issue happens

Additional info:
Comment 1 Patrick Uiterwijk 2015-09-22 12:32:40 EDT
This was an error in the backport for #1256518, fixing under that bug.

*** This bug has been marked as a duplicate of bug 1256518 ***

Note You need to log in before you can comment on or make changes to this bug.