Bug 126530 - USB wireless KBD & Mouse not detected with .427 + .435
USB wireless KBD & Mouse not detected with .427 + .435
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-22 17:12 EDT by Holger Burde
Modified: 2015-01-04 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-27 23:43:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Holger Burde 2004-06-22 17:12:14 EDT
Description of problem:

All Kernels after 2.6.5-1.358 fail to recognise a Fujitsu Siemens USB
wireless Keyboard / Mouse combo.  

Version-Release number of selected component (if applicable):
Kernel 2.6.6-1.427 and .435

How reproducible:

Just load a 2.6.6-1.427 and .435 Kernel and Keyboard and Mouse are
gone. The hardware Detection pops up and with a ps/2 kbd connected 
one can get the info that usb kbd / mouse was removed from the system. 
[both are still connected - the kernel failed to detect them and
assumes they are removed] 

Steps to Reproduce:
1.
2.
3.
  
Actual results:

No input possible (via USB Wirless => Keyboard & Mouse).

Expected results:

Input via USB wireless Keyboard & Mouse

Additional info:

Any Kernel up to 2.6.5-1.358 does _not_ have this problem.
Comment 1 T.Terlemez 2004-07-01 11:43:55 EDT
Hello

I have a similar problem too !
My Usb stick was working with Fedora 2 kernel. But when I update
kernel to 2.6.6-1.427 or .435 it didn't worked. I used modprobe etc.
to load usb-storage, it seems loaded but not working. 
Before it can be mounted as /dev/sda1 but it is not working now. 
I couldn't find and see any solution at internet for this problem.

My usb stick's brand is Alphadrive (I couldn't find www site for it.)
It is working with latest Mandrake 2.6.X kernels.
Comment 2 T.Terlemez 2004-07-03 21:48:41 EDT
Hello

My problem solved with kernel-2.6.6-1.435.2.3.i586. You can try this
kernel (or its 686 type, I didn't try to use it.)
Comment 3 Holger Burde 2004-07-26 17:00:49 EDT
At least with Kernel 2.6.6-1.435.2.3 the option  acpi=off in
/boot/grub.conf solved this nasty problem.
Comment 4 Dave Jones 2005-04-16 00:33:39 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.
Comment 5 Holger Burde 2005-04-16 04:44:00 EDT
Later FC2 Kernels didn't have that Bug anymore but its back in FC4 and RHEL4. 
I found the same Bug in FC4 Test1 and RHEL4 - only the Kernel from the installer
is affected. After Booting the 1st time from disk it works again. The acpi=off
workaround does not work in these cases.
Comment 6 Dave Jones 2005-04-16 14:22:20 EDT
The kernel itself is exactly the same for the installer and the final installed
image. The only thing I can think of is that the installer isn't loading some
module which we load on firstboot.

Jeremy, ideas ?
Comment 7 Jeremy Katz 2005-04-16 15:07:54 EDT
We use the i586 kernel for the install images and the i686 kernel post-install
(for i686 boxes at least).  Could be some config skew between the two?
Comment 8 Dave Jones 2005-04-16 16:03:12 EDT
ah good point, I'd forgotten about the 586 kernel.

the config differences dont point at any obvious problem though.

-CONFIG_M586=y
+# CONFIG_M586 is not set
-# CONFIG_M686 is not set
+CONFIG_M686=y
-CONFIG_X86_F00F_BUG=y
-CONFIG_X86_ALIGNMENT_16=y
+CONFIG_X86_GOOD_APIC=y
+CONFIG_X86_USE_PPRO_CHECKSUM=y
+CONFIG_X86_TSC=y

-# CONFIG_MICROCODE is not set
+CONFIG_MICROCODE=m

-# CONFIG_PROFILING is not set
+CONFIG_PROFILING=y
+CONFIG_OPROFILE=m


Very puzzling.
Can one of you who sees this problem download the 586 kernel and install that,
boot it, boot back to the working kernel, and then fish through
/var/log/messages to get the boot messages from the 586 kernel, and attach that
here. Also post the messages from the working 686 kernel. Maybe we can see
something interesting in the diff output.

Comment 9 Dave Jones 2005-06-27 19:29:30 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 10 Dave Jones 2005-09-30 02:38:15 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 11 Dave Jones 2005-11-10 14:41:05 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 12 Dave Jones 2005-12-27 23:43:45 EST
This bug has been mass-closed along with other bugs that have been in NEEDINFO
state for several months.

Due to the large volume of inactive bugs in bugzilla, this is the only method we
have of cleaning out stale bug reports where the reporter has disappeared.

If you can reproduce this bug after installing all the current updates, please
reopen this bug.

If you are not the reporter, you can add a comment requesting it be reopened,
and someone will get to it asap.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.