Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1265310 - No icon in application menu
Summary: No icon in application menu
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfburn
Version: 22
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1199222 1240879 (view as bug list)
Depends On:
Blocks: F23FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-09-22 15:54 UTC by Raphael Groner
Modified: 2015-12-04 21:20 UTC (History)
10 users (show)

Fixed In Version: xfburn-0.5.4-3.fc23 xfburn-0.5.4-3.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 21:20:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Raphael Groner 2015-09-22 15:54:43 UTC
Description of problem:
There's no icon in application menu for the xfburn entry.

Version-Release number of selected component (if applicable):
xfburn-0.5.4-2.fc23.x86_64
(as in Fedora-Live-Xfce-x86_64-23_Beta-1.iso, 2015-09-22)

How reproducible:
yes

Steps to Reproduce:
1. boot Fedora 23
2. login to Xfce session
3. look into applications menu and find Xfburn entry

Actual results:
no icon

Expected results:
icon visible near the menu entry

Additional info:
This seems to be a regression, still looking for the old bug.

Comment 1 Raphael Groner 2015-09-22 15:56:05 UTC
*** Bug 1199222 has been marked as a duplicate of this bug. ***

Comment 2 Raphael Groner 2015-09-22 16:04:32 UTC
It would be nice to see this fixed in F23 final.
"Each entry on the default system menu layout should have an appropriate icon"
https://fedoraproject.org/wiki/QA:Testcase_desktop_menus

Comment 3 Fedora Blocker Bugs Application 2015-09-22 16:05:34 UTC
Proposed as a Blocker for 23-final by Fedora user raphgro using the blocker tracking app because:

 There's no icon in application menu for the xfburn entry.

It would be nice to see this fixed in F23 final.
"Each entry on the default system menu layout should have an appropriate icon"
https://fedoraproject.org/wiki/QA:Testcase_desktop_menus

Comment 4 Fedora Blocker Bugs Application 2015-09-22 16:09:03 UTC
Proposed as a Freeze Exception for 23-final by Fedora user raphgro using the blocker tracking app because:

 Freeze exception is also okay for me, cause no icon is better than a functionality breakage in an official release, the latter is not the case.

Comment 5 Raphael Groner 2015-09-22 16:11:49 UTC
CC maintainers of Xfce spin

Comment 6 Raphael Groner 2015-09-22 16:19:01 UTC
Really odd. I fail to reproduce in an updated F23 system and see an icon there, it's also xfburn-0.5.4-2.fc23.x86_64 .

Comment 7 Mukundan Ragavan 2015-09-23 01:00:12 UTC
(In reply to Raphael Groner from comment #6)
> Really odd. I fail to reproduce in an updated F23 system and see an icon
> there, it's also xfburn-0.5.4-2.fc23.x86_64 .

Hmmm .... I think I am still seeing this with the Adwaita icon theme (default).

Let me also look.

Comment 8 Raphael Groner 2015-09-23 08:15:07 UTC
(In reply to Mukundan Ragavan from comment #7)
> (In reply to Raphael Groner from comment #6)
> > Really odd. I fail to reproduce in an updated F23 system and see an icon
> > there, it's also xfburn-0.5.4-2.fc23.x86_64 .
> 
> Hmmm .... I think I am still seeing this with the Adwaita icon theme
> (default).
> 
> Let me also look.

You're right, it's the Adwaita theme missing somehow the icon. It shows when I choose Fedora (default) theme in Appearance>Icons settings.
Reassign this bug to Adwaita?

Comment 9 Mukundan Ragavan 2015-09-24 00:52:42 UTC
Let me look a little more. I am seeing no icon with Fedora either.

I typically use Faenza (not in repos) so I had not noticed earlier ... :(

Comment 10 Michael Catanzaro 2015-09-26 01:17:24 UTC
(In reply to Raphael Groner from comment #2)
> It would be nice to see this fixed in F23 final.
> "Each entry on the default system menu layout should have an appropriate
> icon"
> https://fedoraproject.org/wiki/QA:Testcase_desktop_menus

Note that the blocker criteria apply only to Fedora products and also to the KDE spin. The Xfce spin is not release-blocking since it's a smaller community; sorry. :(

This is only an Adwaita bug if a standard named icon is missing (unlikely but possible). Please, check xfburn's desktop file to see the name of the icon it's using, then check it against the list of icons at [1]. Note that applications are expected to ship their own icons, and relying on system icons is strongly discouraged. (But even many GNOME apps still do; xfburn is far from alone.)

[1] http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.html

Comment 11 Raphael Groner 2015-09-26 10:11:17 UTC
The icon is missing wthin the F22 standard spin boot, too. No change done to the theme settings, just booted and logged in with live user from a dd'ed image of an USB stick.

Comment 12 Raphael Groner 2015-09-26 11:08:57 UTC
(In reply to Michael Catanzaro from comment #10)
> (In reply to Raphael Groner from comment #2)
> > It would be nice to see this fixed in F23 final.
> > "Each entry on the default system menu layout should have an appropriate
> > icon"
> > https://fedoraproject.org/wiki/QA:Testcase_desktop_menus
> 
> Note that the blocker criteria apply only to Fedora products and also to the
> KDE spin. The Xfce spin is not release-blocking since it's a smaller
> community; sorry. :(

You're not right. There's the official Xfce spin as there's the KDE spin in parallel with equal policies, I do not see why any dedicated part of the one and big community has any weight here. All of the official spins have to meet the release criteria according to the well defined test cases.

> This is only an Adwaita bug if a standard named icon is missing (unlikely
> but possible). Please, check xfburn's desktop file to see the name of the
> icon it's using, then check it against the list of icons at [1]. Note that
> applications are expected to ship their own icons, and relying on system
> icons is strongly discouraged. (But even many GNOME apps still do; xfburn is
> far from alone.)
> 
> [1]
> http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.
> html

xfburn ships its own icon files, they get placed into hicolor folder, as discussed in the old bug #1199222. Adwaita does not care about that folder, as it seems. The default Fedora theme has a fallback to use the hicolor files.

We can't expect each individual icon theme, as for instance Adwaita is, to ship icons for every possible application. IMHO it's better to fix it in the xfburn package, to get it to work also for any thinkable custom installation outside of the default Xfce packages group.

Mukundan, may I assign this bug to you, as you mention in comment #9 to look deeper for the cause?

Comment 13 Michael Catanzaro 2015-09-26 14:03:05 UTC
(In reply to Raphael Groner from comment #12) 
> You're not right. There's the official Xfce spin as there's the KDE spin in
> parallel with equal policies, I do not see why any dedicated part of the one
> and big community has any weight here. All of the official spins have to
> meet the release criteria according to the well defined test cases.

No, Xfce is simply not release-blocking. See [1]:

"The term release-blocking images means all the images in which bugs are currently considered capable of blocking a Fedora release. The current set of release-blocking images includes the images defined by the three primary Products - Server, Workstation and Cloud - in their product requirement documents and/or technical specifications, and the KDE live image."

Also, for the blocker criterion this violates, you picked "Each entry on the default system menu layout should have an appropriate icon," but that's not one of the blocker criteria, it's a testcase designed to test the following blocker criterion:

"All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy." [1]

which exclusively applies to the Workstation product.

I think a freeze exception for this would be fine, though. Anyway, it's moot, since fortunately I expect you'll have this fixed with plenty of time before the freeze.

[1] https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria

> xfburn ships its own icon files, they get placed into hicolor folder, as
> discussed in the old bug #1199222. Adwaita does not care about that folder,
> as it seems. The default Fedora theme has a fallback to use the hicolor
> files.

No, you can still put icons in hicolor; that works fine. The problem is xfburn doesn't use any of the icons it ships for its application icon. It uses the icon media-cdrom, which was removed from the icon naming spec in 2006 (see appendix A in that spec) [2]. You could change the desktop file to use the icon media-optical instead, but that icon is not intended to be used for application icons, and it's always better to ship your own icons, so it would probably be better to use the icon stock_xfburn.

[2] http://git.xfce.org/apps/xfburn/tree/xfburn.desktop.in

Comment 14 Raphael Groner 2015-09-26 16:11:35 UTC
(In reply to Michael Catanzaro from comment #13)
Thanks for your long explanation.

As written in comment #4, I am fine with a NTH only:

Freeze exception is also okay for me, cause no icon is better than a functionality breakage in an official release, the latter is not the case.

Comment 15 Mukundan Ragavan 2015-09-27 10:41:10 UTC
Raphael, I am good with this being assigned to me. I will get to it later today.

Comment 16 Adam Williamson 2015-09-28 22:17:07 UTC
Discussed at 2015-09-28 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-28/f23-blocker-review.2015-09-28-16.01.html . Accepted as a freeze exception issue - it's good to tidy up this kind of cosmetic issue for the lives, if we can, and the fix ought to be safe.

Comment 17 Fedora Update System 2015-09-30 16:39:18 UTC
xfburn-0.5.4-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-faa6ecaf62

Comment 18 Fedora Update System 2015-10-01 23:53:24 UTC
xfburn-0.5.4-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xfburn'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-faa6ecaf62

Comment 19 Fedora Update System 2015-10-02 01:49:14 UTC
xfburn-0.5.4-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xfburn'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-faa6ecaf62

Comment 20 Fedora Update System 2015-10-03 17:32:31 UTC
xfburn-0.5.4-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Richard Shaw 2015-11-24 16:25:17 UTC
*** Bug 1240879 has been marked as a duplicate of this bug. ***

Comment 22 Raphael Groner 2015-11-24 18:08:34 UTC
Please fix also in F22, as requested in comment #11 and we see a regression with bug #1240879.

Comment 23 Fedora Update System 2015-11-24 19:16:44 UTC
xfburn-0.5.4-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8aba0d59b1

Comment 24 Fedora Update System 2015-11-26 02:25:54 UTC
xfburn-0.5.4-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xfburn'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8aba0d59b1

Comment 25 Fedora Update System 2015-12-04 21:20:37 UTC
xfburn-0.5.4-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.