Bug 1265332 - CloudForms does not delete old RabbitMQ Queues
CloudForms does not delete old RabbitMQ Queues
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.3.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.4.6
Assigned To: Greg Blomquist
Nandini Chandra
openstack
: ZStream
Depends On: 1265289 1265335
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 12:55 EDT by Chris Pelland
Modified: 2016-05-27 19:47 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1265289
Environment:
Last Closed: 2016-05-27 19:47:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2015-09-22 12:55:23 EDT
+++ This bug was initially created as a clone of Bug #1265289 +++

When CFME disconnects from the RabbitMQ service, it leaves behind queues that are still bound to exchanges.  The major problem with leaving behind the queues is that the queues will continue to receive messages and this causes the RabbitMQ process to consume memory unbounded until it dies unexpectedly.

How to reproduce:

0. Install the RabbitMQ Management Plugin:  https://www.rabbitmq.com/management.html on an OpenStack environment. (Double check it's not installed first)
1. Add CFME to the OpenStack environment, wait for the event catcher worker to fully start
2. Browse to RabbitMQ Management web ui (http://openstack_ip:15672), login with Rabbit credentials, click the "Queues" tab, look for queues named "miq-<cfme-ip_address>"
  * miq-<cfme-ip_address>-cinder
  * miq-<cfme-ip_address>-glance
  * miq-<cfme-ip_address>-nova
  * miq-<cfme-ip_address>-quantum
3. Disconnect CFME from OpenStack environment (remove provider from CFME)
4. Browse to RabbitMQ Management web ui and look for queues named "miq-<cfme-ip_adddress>"

Expected Results:

There should be no queues called:  "miq-<cfme-ip_address>"

Actual Results:

There are four queues remaining called:
  * miq-<cfme-ip_address>-cinder
  * miq-<cfme-ip_address>-glance
  * miq-<cfme-ip_address>-nova
  * miq-<cfme-ip_address>-quantum

--- Additional comment from Greg Blomquist on 2015-09-22 11:01:53 EDT ---

For CFME 5.3 and earlier, the queue that's left behind is actually called "notifications.*".  That's a literal "notifications.*".  Note that there are openstack-specific queues called "notifications.info" and "notifications.error" that will remain after CFME is disconnected.

After this bug is fixed, when there is no CFME connected to an openstack environment, there should be no queues called:

  * miq-<cfme-ip_address>-cinder
  * miq-<cfme-ip_address>-glance
  * miq-<cfme-ip_address>-nova
  * miq-<cfme-ip_address>-quantum
  * notifications.*
Comment 3 Nandini Chandra 2015-10-06 18:39:28 EDT
Tested 5.4.3

After removing an Openstack env(rhos6) from CFME,these queues still exist.

  * miq-<cfme-ip_address>-cinder
  * miq-<cfme-ip_address>-glance
  * miq-<cfme-ip_address>-nova
  * miq-<cfme-ip_address>-quantum
Comment 9 Greg Blomquist 2016-05-27 19:47:11 EDT
Closing this since we're moving to using Ceilometer for collecting events.

Note You need to log in before you can comment on or make changes to this bug.