Bug 1265364 - gtk_show_uri() reports success, but otherwise fails under Wayland
gtk_show_uri() reports success, but otherwise fails under Wayland
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 14:37 EDT by Stephen Gallagher
Modified: 2015-10-26 17:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 17:02:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test.c (484 bytes, text/plain)
2015-09-23 04:21 EDT, Milan Crha
no flags Details

  None (edit)
Description Stephen Gallagher 2015-09-22 14:37:06 EDT
Description of problem:
When running Evolution on gnome-shell running under Wayland, clicking on URLs in emails will not launch the default browser (or any other) to display them. This works properly when running under X11

Version-Release number of selected component (if applicable):
evolution-3.17.92-1.fc23.x86_64
gnome-shell-3.17.92-1.fc23.x86_64
wayland-1.8.93-1.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Log into a "GNOME on Wayland" desktop session
2. Launch Evolution (configured with at least one email account)
3. Select an email with a clickable URL
4. Click on the URL

Actual results:
Nothing happens, regardless of the running state of a browser.

Expected results:
The link should come up in the default browser (with the browser launched if not currently running)

Additional info:
Comment 1 Milan Crha 2015-09-23 04:21 EDT
Created attachment 1076119 [details]
test.c

Thanks for a bug report. I tried to reproduce this and I was kind of able to do it too. First of all, evolution uses gtk_show_uri() function for these purposes. I can offer you a simple test application which does just that. I see that evolution calls it, and it succeeds.

The problem is with some underlying executable being used by the gtk_show_uri() (whatever it calls it), which fails to start under Wayland. I see critical runtime warnings on console about incorrect cast to GDK's X11 structure, when GDK's Wayland structure is being used, when clicking the URL within the evolution.

Running the attached test application results in:
   $ ./test
   Successfully showed URI
   [user@localhost ~]$ Unable to init server: Broadway display type not
   supported: Wayland
   Error: cannot open display: Wayland

The "Successfully showed URI" is printed by the test application, the rest is the child executable error printing.

This is not anything in the firefox-40.0.3-1.fc23.x86_64, I can run it under Wayland without any issue.

I'm moving this to gtk3, because I do not know what exactly the gtk_show_uri() does in the background.
Comment 2 Fedora Update System 2015-10-22 16:07:25 EDT
glib2-2.46.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f95b0c8f45
Comment 3 Fedora Update System 2015-10-26 17:02:14 EDT
glib2-2.46.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.