Bug 1265366 - sss_override segfaults when accidentally adding --help flag to some commands
Summary: sss_override segfaults when accidentally adding --help flag to some commands
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Březina
QA Contact: Dan Lavu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-22 19:02 UTC by Dan Lavu
Modified: 2020-05-02 18:11 UTC (History)
8 users (show)

Fixed In Version: sssd-1.14.0-0.1.alpha.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:11:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 3843 0 None None None 2020-05-02 18:11:04 UTC
Red Hat Product Errata RHEA-2016:2476 0 normal SHIPPED_LIVE sssd bug fix and enhancement update 2016-11-03 14:08:11 UTC

Description Dan Lavu 2015-09-22 19:02:05 UTC
Description of problem:
Small bug, but trying to get more information from some of the sss_override options, adding --help to certain options will cause sss_override to segfault. 

Version-Release number of selected component (if applicable):
sssd-client-1.13.0-33.el7.x86_64


How reproducible:
Always

Steps to Reproduce:
1. sss_override user-del --help
2.
3.

Actual results:
[root@sssd1-13-0-29 ~]# sss_override user-del --help
Segmentation fault (core dumped)


Expected results:
Print help

[root@sssd1-13-0-29 ~]# sss_override user-del 
Missing option: Specify name of modified object.

Usage: sss_override user-del NAME

Common options:
  --debug=INT            Enable debug at level



Additional info:

Comment 3 Lukas Slebodnik 2015-09-23 07:31:01 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2802

Comment 4 Lukas Slebodnik 2015-10-02 10:33:46 UTC
master:
* bda8039465a0084fb380e878c8f9ea3e900505ea

sssd-1-13:
* 4d5e7e548865bffec5b8656ecb81c73887949c75

Comment 5 Mike McCune 2016-03-28 23:16:15 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 7 Dan Lavu 2016-08-15 19:16:45 UTC
Verified against sssd-client-1.14.0-18.el7.x86_64. 

         
[root@cloud-qe-14 ~]# sss_override --help
Usage:
sss_override COMMAND COMMAND-ARGS

Available commands:
*                                 user-add
*                                 user-del
*                                user-find
*                                user-show
*                              user-import
*                              user-export
*                                group-add
*                                group-del
*                               group-find
*                               group-show
*                             group-import
*                             group-export

Common options:
  --debug=INT 	 The debug level to run with

Help options:
  -?, --help  	 Show this for a command
  --usage     	 Show brief usage message for a command


[root@cloud-qe-14 ~]# sss_override user-add --help
Usage: sss_override user-add NAME [OPTIONS...]

Command options:
  -n, --name=STRING            Override name
  -u, --uid=INT                Override uid (non-zero value)
  -g, --gid=INT                Override gid (non-zero value)
  -h, --home=STRING            Override home directory
  -s, --shell=STRING           Override shell
  -c, --gecos=STRING           Override gecos
  -x, --certificate=STRING     Override certificate

Common options:
  --debug=INT                  The debug level to run with

Help options:
  -?, --help                   Show this help message
  --usage                      Display brief usage message

Comment 9 errata-xmlrpc 2016-11-04 07:11:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2476.html


Note You need to log in before you can comment on or make changes to this bug.