Bug 1265407 - No protocol specified java.lang.NullPointerException when using console mode or automatic script
No protocol specified java.lang.NullPointerException when using console mode ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: 6.3.0
Assigned To: Thomas Hauser
Filip Elias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 16:35 EDT by Cojan van Ballegooijen
Modified: 2016-08-24 07:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If the user tries to install the product in console mode or by using an automatic script, they may encounter an exception if tehy are logged in as the root user. To work around this issue, ensure you log in as a JBoss user.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:49:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cojan van Ballegooijen 2015-09-22 16:35:57 EDT
Description of problem:
No protocol specified java.lang.NullPointerException when trying to start 
java -jar jboss-dv-installer-6.2.0.redhat-2.jar -console
or
java -jar jboss-dv-installer-6.2.0.redhat-2.jar <file-name>.xml


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. RHEL TigerVNC to server with RHEL and configured to logon as root initially
2. su - jboss
3. start the installer using the above options

Actual results:
No protocol specified java.lang.NullPointerException

Expected results:
I don't expect to have any Nullpointer exception since I'm using console mode installation. Nevertheless the problem ws solved when TigerVNC logged in as the jboss user and not as root initially.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.