Bug 1265417 - When rabbitmq is partitionned, heat-apis will break and never come back
When rabbitmq is partitionned, heat-apis will break and never come back
Status: CLOSED DUPLICATE of bug 1265418
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Zane Bitter
Amit Ugol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 17:19 EDT by David Hill
Modified: 2016-04-26 16:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 09:09:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hill 2015-09-22 17:19:20 EDT
Description of problem:
When rabbitmq is partitionned, heat-apis will break and never come back even when the rabbitmq cluster is back to a normal state

Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1. Get HA rabbitmq cluster
2. Get heat-api running
3. Partition rabbitmq (iptables, kill a node, etc)
4. Heat breaks, every services breaks
5. Fix rabbit MQ
6. All services comes back but not heat-api

Actual results:
Broken heat-apis

Expected results:
Working heat-apis

Additional info:
We're able to reproduce this issue on request.
Comment 2 Zane Bitter 2015-09-23 09:09:43 EDT

*** This bug has been marked as a duplicate of bug 1265418 ***

Note You need to log in before you can comment on or make changes to this bug.