Bug 126542 - im-switch overwrites existing content in /etc/sysconfig/i18n and/or ~/.i18n
Summary: im-switch overwrites existing content in /etc/sysconfig/i18n and/or ~/.i18n
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: im-sdk   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: IIIMF
TreeView+ depends on / blocked
 
Reported: 2004-06-22 22:24 UTC by Chong Kai Xiong
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 11.4-46.svn1587
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-26 02:53:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chong Kai Xiong 2004-06-22 22:24:09 UTC
Description of problem:
Using im-switch to change the system-wide or user-specific input
method completely overwrites existing content of /etc/sysconfig/i18n
and ~/.i18n respectively.

Version-Release number of selected component (if applicable):
iiimf-x-11.4-43

How reproducible:
Always

Steps to Reproduce:
1. start with non-empty and writeable /etc/sysconfig/i18n (or ~/.i18n)
2. set system wide input method as root with: im-switch -w -m method
(or im-switch -m method)

Actual results:
Existing content of /etc/sysconfig/i18n (or ~/.i18n) is completely
overwritten, leaving only the line: "XIM=method".

Expected results:
The "XIM=" line should be appended if it does not already exist.
Otherwise, it should be changed to the requested method.

Additional info:
The problem is caused by the following line in /usr/bin/im-switch:

  echo "XIM=$1" > /tmp/imswitcher$$

It should be '>>' instead of '>'.

Comment 1 Jens Petersen 2004-06-23 03:07:53 UTC
Thanks for catching this.

The fix has been committed for FC/devel and should appear
the next time im-sdk gets built.

Comment 2 Jens Petersen 2004-06-23 14:13:12 UTC
Fixed FC2 package 11.4-46.svn1587 should be appearing in
updates/testing/2 before long.


Note You need to log in before you can comment on or make changes to this bug.