Bug 1265519 - Reference for all installation options of both katello-installer and capsule-installer
Reference for all installation options of both katello-installer and capsule-...
Status: CLOSED DEFERRED
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Hayley Hudgeons
David O'Brien
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 02:44 EDT by Fred van Zwieten
Modified: 2015-11-23 08:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 08:36:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred van Zwieten 2015-09-23 02:44:20 EDT
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Installation_Guide/index.html

Section Number and Name: 

Describe the issue:
katello-installer and capsule-installer both have an intimidating and ever growing list of installation options. There should be a reference section on all these options. What do they mean? How do they interact? 

Suggestions for improvement:
Create an appendix in the installation guide and create a full reference for all these installation options.

Additional information:
Comment 1 David O'Brien 2015-10-15 19:12:35 EDT
Hi Fred

I agree the list of options is long and at first view a lot to take in. In the product doc we attempt to keep the list of options to those required for a typical installation (if there is such a thing :) )


Are you requesting that we include the output of (e.g.), katello-installer --help in the formal docs, as an appendix?

We generally don't include this type of information because:

a) it's available in its current form
b) changes to the command and its options are *usually* quickly reflected in the help pages
c) it's a lot of overhead to reproduce and keep up-to-date in the product docs

If there is more or different information that you'd like to see, that's not currently available, please let us know.

thanks
Comment 2 Fred van Zwieten 2015-11-23 07:14:34 EST
Yeah, well ok. It's just that the help text if pretty short. And the different documented scenario's do not cover *all* options. It was something a customer was wondering (where is the reference on all these options?).
Comment 3 David O'Brien 2015-11-23 08:15:05 EST
Granted, the help text can be brief, and we don't document all possible scenarios or options, we just don't have the resources.

If there are specifics that customers regular raise then I'm sure it make a bright spot on our radar, and either Hayley or Andrew will schedule something as soon as possible.

Thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.