Bug 1265522 - Geo-Replication failes on uppercase hostnames
Geo-Replication failes on uppercase hostnames
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Saravanakumar
: ZStream
Depends On: 1264800
Blocks: 1287960
  Show dependency treegraph
 
Reported: 2015-09-23 02:47 EDT by Saravanakumar
Modified: 2016-06-16 09:38 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1264800
: 1287960 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:38:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Saravanakumar 2015-10-01 05:33:01 EDT
Updated Description:

Description of problem:
When using uppercase hostnames for volume creation or for create push-pem geo replication failes

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Either use the uppercase hostname for the slave_host in the 

gluster volume geo-replication MASTER_VOL SLAVE_HOST::SLAVE_VOL create push-pem
command 

OR

create the SLAVE_VOL using the uppercase hostnames

# gluster system:: execute gsec_create
Common secret pub file present at /var/lib/glusterd/geo-replication/common_secret.pem.pub

# gluster vol geo-replication vol01 RHGS3::vol01 create push-pem
Invalid Url: RHGS3::vol01
geo-replication command failed

# gluster vol geo-replication vol01 rhgs3::vol01 create push-pem
Creating geo-replication session between vol01 & rhgs3::vol01 has been successful

# gluster vol geo-replication vol01 rhgs3::vol01 status
 
MASTER NODE    MASTER VOL    MASTER BRICK       SLAVE USER    SLAVE           SLAVE NODE    STATUS     CRAWL STATUS    LAST_SYNCED          
---------------------------------------------------------------------------------------------------------------------------------
rhgs1          vol01         /rhs/brick1/vol    root          rhgs3::vol01    N/A           Created    N/A             N/A                  
rhgs2          vol01         /rhs/brick1/vol    root          rhgs3::vol01    N/A           Created    N/A             N/A                  
[root@rhgs1 .unsupported]# gluster vol geo-replication vol01 rhgs3::vol01 start
Starting geo-replication session between vol01 & rhgs3::vol01 has been successful
[root@rhgs1 .unsupported]# gluster vol geo-replication vol01 rhgs3::vol01 status
 
MASTER NODE    MASTER VOL    MASTER BRICK       SLAVE USER    SLAVE           SLAVE NODE    STATUS    CRAWL STATUS    LAST_SYNCED          
--------------------------------------------------------------------------------------------------------------------------------
rhgs1          vol01         /rhs/brick1/vol    root          rhgs3::vol01    N/A           Faulty    N/A             N/A                  
rhgs2          vol01         /rhs/brick1/vol    root          rhgs3::vol01    N/A           Faulty    N/A             N/A                  


Actual results:
Geo-Replication can not start

Expected results:
Geo-Replication should start
Comment 2 Vijay Bellur 2015-11-23 01:13:36 EST
REVIEW: http://review.gluster.org/12216 (geo-rep: geo-rep to handle CAPS based Hostname) posted (#7) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 3 Vijay Bellur 2015-11-24 06:35:54 EST
REVIEW: http://review.gluster.org/12216 (geo-rep: geo-rep to handle CAPS based Hostname) posted (#8) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 4 Vijay Bellur 2015-12-02 10:35:22 EST
COMMIT: http://review.gluster.org/12216 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit f6142e97c6219d2c1c482a414690020ed1275bdb
Author: Saravanakumar Arumugam <sarumuga@redhat.com>
Date:   Wed Sep 23 12:21:40 2015 +0530

    geo-rep: geo-rep to handle CAPS based Hostname
    
    Problem:
    geo-replication session creation fails when Hostname
    is having CAPS in it.
    Issue is with the regex pattern which handles only small lettered
    Hostname.
    
    Fix:
    Fix the regex pattern to handle CAPS based hostname as well.
    
    Change-Id: I5c99c102e9706acc2b1fab1e6bf158e68beed373
    BUG: 1265522
    Signed-off-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Reviewed-on: http://review.gluster.org/12216
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:38:14 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.