Bug 1265524 - Trying to add review=? flag to attachment ends with nop
Trying to add review=? flag to attachment ends with nop
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Attachments/Requests (Show other bugs)
4.4
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Hao Chang Yu
Rony Gong
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 02:59 EDT by Jakub Jelen
Modified: 2015-12-11 01:57 EST (History)
6 users (show)

See Also:
Fixed In Version: 4.4.10042-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 23:31:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Jelen 2015-09-23 02:59:12 EDT
Description of problem:
Add review flag to attachment succeeds but the flag is not added.

Version-Release number of selected component (if applicable):
current Red Hat bugzilla

How reproducible:
deterministic

Steps to Reproduce:
1. Open existing attachment without flags (https://bugzilla.redhat.com/attachment.cgi?id=1074917&action=edit)
2. Select review flag and "?"
3. Write email/select email from offered list
4. Press submit

Actual results:
Flag is not added, nothing is modified, no mail is sent

Expected results:
Flag is added and appropriate person notified.

Additional info:
I was trying with attachment #1074917 [details] from above link and trying to add review flag to colleague who has me on his watch list, if it is important.
Comment 1 Jason McDonald 2015-09-23 03:31:48 EDT
I can reproduce this problem on both Production and on Partner Bugzilla.  Despite Bugzilla failing to add the requested flag, no error message was shown in the UI.  Bugzilla itself thinks no change was made, and thus it excluded all users from receiving an email notification of the (non-)change.
Comment 2 Rony Gong 2015-09-23 03:36:35 EDT
This issue could be reproduced in bugzilla QE test environment, QE indeed missed this kind of situation. The only way to set attachment review flag is setting flag when adding an attachment.
Comment 3 Hao Chang Yu 2015-09-29 02:08:42 EDT
Note: This bug was caused by Bug 1188085
Comment 4 Rony Gong 2015-10-14 02:12:41 EDT
Tested on 
QA environment(bzperfweb01.app.qa) with version(4.4.10042-1, DB: psql)
Result: Pass
Comment 5 Matt Tyson 2015-11-03 23:31:10 EST
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.