Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1265562 - Spice-gtk incorrectly reports failed file transfer
Summary: Spice-gtk incorrectly reports failed file transfer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk
Version: 7.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 7.3
Assignee: Jonathon Jongsma
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-23 08:43 UTC by Tomas Jamrisko
Modified: 2016-11-04 01:10 UTC (History)
8 users (show)

Fixed In Version: spice-gtk-0.26-6.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 01:10:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2229 0 normal SHIPPED_LIVE virt-viewer, libgovirt, spice-gtk, and usbredir bug fix and enhancement update 2016-11-03 13:26:58 UTC

Description Tomas Jamrisko 2015-09-23 08:43:44 UTC
Description of problem:
spice-gtk incorrectly reports failed file transfer, even though the transfer completed succesfully.

Version-Release number of selected component (if applicable):
spice-gtk-0.26-5.el7

How reproducible:
~ 70%

Steps to Reproduce:
1. Drag and drop (multiple) files from client to guest and have --spice-debug enabled.

Actual results:
spice-gtk logs File ${name} xfer failed: transfer received success in pending state
Hashes of original and transferred files match

Expected results:
It was a successful transfer

Comment 2 Victor Toso 2015-09-23 08:51:52 UTC
> Actual results:
> spice-gtk logs File ${name} xfer failed: transfer received success in
> pending state
> Hashes of original and transferred files match
> 
> Expected results:
> It was a successful transfer

This does not seem like a bug.
This is a debug message to show that something happened during the file transfer.

Comment 3 Pavel Grunt 2015-09-23 09:57:16 UTC
What is the guest ?
Can you reproduce it with both Windows and RHEL as a guest ?

Comment 5 Tomas Jamrisko 2015-09-23 12:36:15 UTC
(In reply to Victor Toso from comment #2)

> This does not seem like a bug.
> This is a debug message to show that something happened during the file
> transfer.

It happens at the end of file transfer, where "transferred file x of size y in z seconds" is expected (as it happens with some other files). As mentioned, transfer itself is OK, so yes, it's an issue with debug message as Pavel says.
 

(In reply to Pavel Grunt from comment #3)
> What is the guest ?
> Can you reproduce it with both Windows and RHEL as a guest ?

Yes, it can be reproduced both with windows and rhel guests.

Comment 6 Jonathon Jongsma 2015-10-20 14:26:50 UTC
I managed to reproduce this. In my (brief) testing, it seems to only happen when you're transferring multiple files, and only when one of the files is quite small.

Comment 7 Jonathon Jongsma 2015-10-21 21:11:36 UTC
patch posted here: http://lists.freedesktop.org/archives/spice-devel/2015-October/022582.html

Comment 11 errata-xmlrpc 2016-11-04 01:10:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html


Note You need to log in before you can comment on or make changes to this bug.