Bug 1265565 - Collect Logs FTP input screen layout broken
Collect Logs FTP input screen layout broken
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.3.0
Unspecified Unspecified
medium Severity low
: GA
: 5.5.0
Assigned To: Robin Knaur
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 04:48 EDT by Pete Savage
Modified: 2015-11-11 15:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 08:15:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bad Layout (27.76 KB, image/png)
2015-09-23 04:48 EDT, Pete Savage
no flags Details
Current layout in master (71.50 KB, image/png)
2015-09-30 08:16 EDT, Robin Knaur
no flags Details

  None (edit)
Description Pete Savage 2015-09-23 04:48:34 EDT
Created attachment 1076124 [details]
Bad Layout

Description of problem: Collect Logs FTP input screen layout broken


Version-Release number of selected component (if applicable): 5.5.0.1


How reproducible: 100%


Steps to Reproduce:
1. Goto: Configure -> Configuration -> Diagnostics -> Collect Logs
2. Click Edit button
3. Change type to FTP

Actual results: Layout of page is messed up


Expected results: Layout should be good


Additional info:
Comment 2 Robin Knaur 2015-09-24 10:01:16 EDT
cant reproduce, because i get similar error as here https://github.com/ManageIQ/manageiq/issues/4472

I get:
 FATAL -- : Error caught: [ActiveRecord::SubclassNotFound] The single-table inheritance mechanism failed to locate the subclass: 'FileDepotFtpAnonymousRedhatDropbox'. This error is raised because the column 'type' is reserved for storing the class in case of inheritance. Please rename this column if you didn't intend it to be used for storing the inheritance class or overwrite FileDepot.inheritance_column to use another column for that information.

But its possible that this bug could have been fixed by converting style1 tables already. Because all partials that have label "Depot Name" are converted, but on screen isnt.
Comment 3 Robin Knaur 2015-09-30 08:15:45 EDT
I was finally able to render this page and in current master is layout ok. This problem was probably caused by incomplete style1 conversion and was fixed by style1 to patternfly converting process.
Comment 4 Robin Knaur 2015-09-30 08:16 EDT
Created attachment 1078609 [details]
Current layout in master

Note You need to log in before you can comment on or make changes to this bug.