Bug 1265566 - sigpending syscall not implemented on aarch64
sigpending syscall not implemented on aarch64
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: valgrind (Show other bugs)
7.2
aarch64 Unspecified
medium Severity medium
: rc
: 7.3
Assigned To: Mark Wielaard
Miloš Prchlík
:
Depends On:
Blocks: 1277314
  Show dependency treegraph
 
Reported: 2015-09-23 04:50 EDT by Miloš Prchlík
Modified: 2016-11-03 22:55 EDT (History)
6 users (show)

See Also:
Fixed In Version: valgrind-3.11.0-20.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 22:55:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 353084 None None None Never

  None (edit)
Description Miloš Prchlík 2015-09-23 04:50:15 EDT
Description of problem:

cat sigpending.c 
#include <signal.h>

int main(int argc, char **argv)
{
  sigset_t ss;

  sigpending(&ss);

  return 0;
}

leads to:

==9121== Copyright (C) 2002-2013, and GNU GPL'd, by Julian Seward et al.
==9121== Using Valgrind-3.10.0 and LibVEX; rerun with -h for copyright info
==9121== Command: /tmp/tmp.JXCBD0Zctt/sigpending
==9121== Parent PID: 8291
==9121== 
--9121-- WARNING: unhandled syscall: 136
--9121-- You may be able to write your own handler.
--9121-- Read the file README_MISSING_SYSCALL_OR_IOCTL.
--9121-- Nevertheless we consider this a bug.  Please report
--9121-- it at http://valgrind.org/support/bug_reports.html.
==9121== 
==9121== HEAP SUMMARY:
==9121==     in use at exit: 0 bytes in 0 blocks
==9121==   total heap usage: 0 allocs, 0 frees, 0 bytes allocated
==9121== 
==9121== All heap blocks were freed -- no leaks are possible
==9121== 
==9121== For counts of detected and suppressed errors, rerun with: -v
==9121== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 0 from 0)

This was revealed by running a reproducer for https://bugzilla.redhat.com/show_bug.cgi?id=1225964 - which was reported against ppc64. I can't see qemu - which was mentioned as an example of apps that are limited by this on pp64 - available for aarch64 though.


Version-Release number of selected component (if applicable):

valgrind-3.10.0-16.el7.aarch64


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Mark Wielaard 2015-09-23 08:17:22 EDT
Fixed by in valgrind svn r15676
Comment 3 Mark Wielaard 2016-01-05 15:36:52 EST
The upstream patch mentioned in comment #1 can be backported.
Comment 5 Miloš Prchlík 2016-06-06 10:15:56 EDT
QA note: sigpending syscall support (or rt_sigpending, since aarch64 does not have sigpending) is covered by valgrind's ./memcheck/tests/arm64-linux/scalar.c test.
Comment 6 Miloš Prchlík 2016-06-08 08:55:01 EDT
Verified for build valgrind-3.11.0-22.el7.
Comment 8 errata-xmlrpc 2016-11-03 22:55:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2297.html

Note You need to log in before you can comment on or make changes to this bug.