Bug 1265578 - rpm-plugin-systemd-inhibit would deserve some documentation
rpm-plugin-systemd-inhibit would deserve some documentation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Florian Festi
Karel Srot
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 05:23 EDT by Karel Srot
Modified: 2016-11-04 00:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: rpm-4.11.3-18.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:37:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2015-09-23 05:23:10 EDT
Description of problem:

As we have backported the plugin to 7.2 (bug 1160401) it would be good to have it also documented, e.g. in a for of a manpage or at least README file.

Version-Release number of selected component (if applicable):
rpm-plugin-systemd-inhibit-4.11.3-17.el7

# rpm -ql rpm-plugin-systemd-inhibit.
/usr/lib64/rpm-plugins
/usr/lib64/rpm-plugins/systemd_inhibit.so

No doc.
Comment 3 Karel Srot 2016-07-08 03:18:37 EDT
Hi Florian,
I can see you have added the man page and it is part of the rpm package. Is there a reason for not shiping it with the rpm-plugin-systemd-inhibit subpackage itself? For example rpm-sign subpackage ships the man page on its own.

# rpm -ql rpm | grep plugin
/usr/share/man/man8/rpm-plugin-systemd-inhibit.8.gz
# rpm -ql rpm-plugin-systemd-inhibit
/usr/lib64/rpm-plugins
/usr/lib64/rpm-plugins/systemd_inhibit.so
# rpm -ql rpm-sign
/usr/bin/rpmsign
/usr/share/man/man8/rpmsign.8.gz
Comment 4 Karel Srot 2016-07-27 07:22:17 EDT
It doesn't make sense to do another respin just due to changing the file location. Therefore I have file new bug 1360706 regarding the man page location.
Comment 7 errata-xmlrpc 2016-11-04 00:37:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2359.html

Note You need to log in before you can comment on or make changes to this bug.