This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 126561 - (blackhat) KDE Konsole kills children
KDE Konsole kills children
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-23 05:21 EDT by Nicola Degara
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 11:57:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicola Degara 2004-06-23 05:21:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
Hi guys. 
I was not able to find the component konsole in the list of the
"products" so I have choosen the xterm... please be patient!

I have found a strange thing from the previous version, infact if I
start an application from the console by typing [myapplication &], the
application will start correctely but when I close the konsole the
same program (obviously child of the current console) will be killed.

I do not understand if it is a feature or a bug. :-)
Also because if you use ssh you can start remote application without
loose their run status after the exit.


Version-Release number of selected component (if applicable):
1.3.2

How reproducible:
Always

Steps to Reproduce:
1.type in konsole> gkrellm &
2.close konsole
3.bye bye application
    

Actual Results:  The child application dies

Expected Results:  I do not know if it is a bug or a feature

Additional info:

I will put as enhancement in order to avoid any misunderstanding for
my ticket.
Comment 1 Ngo Than 2004-06-23 11:57:11 EDT
It does not have to do with konsole! konsole does not kill the child
application. It looks like the windows manager does it here.

if you terminate konsole with "exit", your child applications still run.

I don't think it's a bug.
Comment 2 Nicola Degara 2004-06-24 00:41:29 EDT
dear Than,
  your "it looks like" means that it is a behaviour of the windows
manager right?
It is not a bug of the console and for this I trust you but I do not
think it is the right behaviour for the windows manager.

Anyway if you try to start a X application it will be killed and the
PID will killed also. (in the past version this worked in this way!)
Bye

Nicola
Comment 3 Havoc Pennington 2004-06-24 14:30:21 EDT
This is correct, when a shell exits it kills its child processes.

To avoid this do:

bash$ mycommand &
bash$ disown

Note You need to log in before you can comment on or make changes to this bug.