Bug 126563 - pci.h for mmconfig.c missing in kernel-sourcecode-2.6.6-1.435
pci.h for mmconfig.c missing in kernel-sourcecode-2.6.6-1.435
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-23 06:34 EDT by Phil Dybvig
Modified: 2015-01-04 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 00:18:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Dybvig 2004-06-23 06:34:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
Compiling the kernel with defaults in menuconfig fails because
/usr/src/linux-2.6.6-1.435/arch/x86_64/pci/mmconfig.c cannot find the
include file pci.h it needs.  Copying the pci.h from
/usr/src/linux-2.6.6-1.435/arch/i386/pci/ to
/usr/src/linux-2.6.6-1.435/arch/x86_64/pci/ permits compilation but
may have completely improper settings and is not necessarily a fix.

Version-Release number of selected component (if applicable):
kernel-sourcecode-2.6.6-1.435

How reproducible:
Always

Steps to Reproduce:
1.mkdir /home/myname/build;mkdir /home/myname/build/kernel
2.MYBUILD=/home/myname/build/kernel;export MYBUILD
3.cd /usr/src/linux-2.6.6-1.435
4.make O=$MYBUILD mrproper
5.make O=$MYBUILD menuconfig    (simply select exit and yes to save)
6.make O=$MYBUILD 

Actual Results:  compile fails in
/usr/src/linux-2.6.6-1.435/arch/x86_64/pci/mmconfig.c with an error
indicating pci.h was not found

Expected Results:  compile should not fail :-)
Comment 1 Phil Dybvig 2004-06-23 18:09:55 EDT
I just downloaded 2.6.7 from kernel.com and the same compilation
problem occurs.  Either they are missing the pci.h they should have
(probably) or there is a problem with the default configuration.
Obviously, the FC2 distro kernels were not compiled this way (the
compile fails) and probably used different defaults.  If the
defaults we should use to recompile the same kernel are provided in
the FC2 core distro, I don't know where they are.
Comment 2 Dave Jones 2004-11-27 15:18:57 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?

Note You need to log in before you can comment on or make changes to this bug.