Bug 1265633 - AFR : "gluster volume heal <volume_name info" doesn't report the fqdn of storage nodes.
AFR : "gluster volume heal <volume_name info" doesn't report the fqdn of stor...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
: Triaged
Depends On: 1265470
Blocks: 1055968 glusterfs-3.7.5
  Show dependency treegraph
 
Reported: 2015-09-23 07:54 EDT by Ravishankar N
Modified: 2015-10-14 06:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1265470
Environment:
Last Closed: 2015-10-14 06:28:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2015-09-23 07:54:34 EDT
+++ This bug was initially created as a clone of Bug #1265470 +++

Description of problem:
============================
When a volume is created with bricks containing fully qualified domain names of the storage nodes, "gluster volume heal <volume_name> info" should also output fqdn of the storage node like "info healed" and "info split-brain"

Version-Release number of selected component (if applicable):
===============================================================
glusterfs 3.4.0.57rhs built on Jan 13 2014 06:59:05

How reproducible:
===================
Often

Steps to Reproduce:
===================
1. Create a replicated volume with bricks having the fqdn of the storage nodes. Start the volume. 

2. Bring down a brick offline. 

3. Create fuse mount. Create few files and directories. 

4. Execute "gluster volume heal <volume_name> info"

Actual results:
====================
root@domU-12-31-39-0A-99-B2 [Jan-20-2014- 6:30:51] >gluster v heal importer info | grep "Brick"
Brick domU-12-31-39-0A-99-B2:/rhs/bricks/importer/
Brick ip-10-82-210-192.ec2.internal:/rhs/bricks/importer
Brick ip-10-234-21-235:/rhs/bricks/importer/
Brick ip-10-2-34-53:/rhs/bricks/importer/
Brick ip-10-114-195-155:/rhs/bricks/importer/
Brick ip-10-159-26-108:/rhs/bricks/importer/

root@domU-12-31-39-0A-99-B2 [Jan-20-2014- 6:29:57] >gluster v heal importer info healed | grep "Brick"
Brick domU-12-31-39-0A-99-B2.compute-1.internal:/rhs/bricks/importer
Brick ip-10-82-210-192.ec2.internal:/rhs/bricks/importer
Brick ip-10-234-21-235.ec2.internal:/rhs/bricks/importer
Brick ip-10-2-34-53.ec2.internal:/rhs/bricks/importer
Brick ip-10-114-195-155.ec2.internal:/rhs/bricks/importer
Brick ip-10-159-26-108.ec2.internal:/rhs/bricks/importer


root@domU-12-31-39-0A-99-B2 [Jan-20-2014- 6:30:07] >gluster v heal importer info split-brain | grep "Brick"
Brick domU-12-31-39-0A-99-B2.compute-1.internal:/rhs/bricks/importer
Brick ip-10-82-210-192.ec2.internal:/rhs/bricks/importer
Brick ip-10-234-21-235.ec2.internal:/rhs/bricks/importer
Brick ip-10-2-34-53.ec2.internal:/rhs/bricks/importer
Brick ip-10-114-195-155.ec2.internal:/rhs/bricks/importer
Brick ip-10-159-26-108.ec2.internal:/rhs/bricks/importer

root@domU-12-31-39-0A-99-B2 [Jan-20-2014- 5:36:11] >gluster v info

Volume Name: exporter
Type: Distributed-Replicate
Volume ID: 31e01742-36c4-4fbf-bffb-bc9ae98920a7
Status: Started
Number of Bricks: 2 x 3 = 6
Transport-type: tcp
Bricks:
Brick1: domU-12-31-39-0A-99-B2.compute-1.internal:/rhs/bricks/exporter
Brick2: ip-10-82-210-192.ec2.internal:/rhs/bricks/exporter
Brick3: ip-10-234-21-235.ec2.internal:/rhs/bricks/exporter
Brick4: ip-10-2-34-53.ec2.internal:/rhs/bricks/exporter
Brick5: ip-10-114-195-155.ec2.internal:/rhs/bricks/exporter
Brick6: ip-10-159-26-108.ec2.internal:/rhs/bricks/exporter 

Expected results:
====================
"gluster volume heal <volume_name> info" should report the fqdn of the storage node.

--- Additional comment from Ravishankar N on 2015-09-23 02:31:41 EDT ---

Patch URL: http://review.gluster.org/#/c/12212/

--- Additional comment from Ravishankar N on 2015-09-23 07:51:36 EDT ---

Patch merged. Not sure why bugzilla is not reflecting the status.
Comment 1 Ravishankar N 2015-09-23 07:57:53 EDT
http://review.gluster.org/#/c/12220/
Comment 2 Pranith Kumar K 2015-10-14 06:28:17 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 3 Pranith Kumar K 2015-10-14 06:37:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.