Bug 1265654 - rpmtest fails in s390x because of grub2
rpmtest fails in s390x because of grub2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jaroslav Škarvada
Tereza Cerna
: Regression
: 1257138 (view as bug list)
Depends On:
Blocks: 1186677
  Show dependency treegraph
 
Reported: 2015-09-23 08:26 EDT by Tereza Cerna
Modified: 2016-07-19 07:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: tuned-2.5.1-4.el7
Doc Type: Bug Fix
Doc Text:
Cause: Previously Tuned RPM patched unconditionally grub configuration files to support alteration of kernel command line through tuned profiles (by using bootloader plugin). But there are architectures like s390(x) where grub isn't supported. Consequence: On such architectures Tuned installation/upgrade ended with error message. Fix: Conditional support for grub was added into Tuned RPM. Result: Now the Tuned RPM scriptlet patches grub configuration files only if grub is installed on the machine and the error is no more triggered on s390(x).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:22:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tereza Cerna 2015-09-23 08:26:58 EDT
Tuned doesn't reflect that grub2 is not in s390x.

From tps - rpmtest:
sed: can't read /etc/default/grub: No such file or directory
warning: %post(tuned-2.5.1-3.el7.noarch) scriptlet failed, exit status 2

# rpm -q tuned
tuned-2.5.1-3.el7.noarch
Comment 1 Jaroslav Škarvada 2015-09-23 08:32:05 EDT
It outputs errors on s390(x) during upgrade. I think it shouldn't do it. It's bad user experience.
Comment 5 errata-xmlrpc 2015-11-19 07:22:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2375.html
Comment 6 Jaroslav Škarvada 2016-07-19 07:46:52 EDT
*** Bug 1257138 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.