Bug 1265690 - Update python-networkx to 1.10
Update python-networkx to 1.10
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: distribution (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Liberty
Assigned To: Alan Pevec
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 09:33 EDT by Javier Peña
Modified: 2016-04-26 18:57 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-networkx-1.10-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cinder logs when reproducing the issue (24.24 KB, application/zip)
2015-09-23 11:28 EDT, Javier Peña
no flags Details

  None (edit)
Description Javier Peña 2015-09-23 09:33:30 EDT
Description of problem:
Using the repo from the RDO test day (http://beta.rdoproject.org/testday/rdo-test-day-liberty-01/), I cannot create any Cinder volumes.

Version-Release number of selected component (if applicable):
openstack-cinder-7.0.0.0b4-dev158.el7.centos.noarch
python-cinderclient-1.4.1-dev2.el7.centos.noarch
python-cinder-7.0.0.0b4-dev158.el7.centos.noarch


How reproducible:
Always

Steps to Reproduce:
1. packstack --allinone using the RDO test day repos
2. . /root/keystonerc_demo
3. cinder create --name test 1

Actual results:
ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-64e18f08-cfd7-43a3-8fdd-a02c28e83559)

The following is found in /var/log/cinder/api.log:

2015-09-23 15:29:48.730 20553 INFO cinder.api.openstack.wsgi [req-64e18f08-cfd7-43a3-8fdd-a02c28e83559 a0c122413fb04accb5fe0623a84185a4 36839f2d92c64213b36cc8a619a7ebd1 - - -] POST http://192.168.122.133:8776/v2/36839f2d92c64213b36cc8a619a7ebd1/volumes
2015-09-23 15:29:48.733 20553 INFO cinder.api.v2.volumes [req-64e18f08-cfd7-43a3-8fdd-a02c28e83559 a0c122413fb04accb5fe0623a84185a4 36839f2d92c64213b36cc8a619a7ebd1 - - -] Create volume of 1 GB
2015-09-23 15:29:48.739 20553 INFO cinder.volume.api [req-d06c9572-9425-4de1-81ad-e57e510d4825 - - - - -] Availability Zones retrieved successfully.
2015-09-23 15:29:48.786 20553 ERROR cinder.api.middleware.fault [req-d06c9572-9425-4de1-81ad-e57e510d4825 - - - - -] Caught error: (MissingDependencies(u"'taskflow.patterns.linear_flow.Flow: volume_create_api(len=5)' requires ['reservations', 'volume_id', 'volume_properties'] but no other entity produces said requirements",),)
2015-09-23 15:29:48.786 20553 INFO cinder.api.middleware.fault [req-d06c9572-9425-4de1-81ad-e57e510d4825 - - - - -] http://192.168.122.133:8776/v2/36839f2d92c64213b36cc8a619a7ebd1/volumes returned with HTTP 500
2015-09-23 15:29:48.787 20553 INFO eventlet.wsgi.server [req-d06c9572-9425-4de1-81ad-e57e510d4825 - - - - -] 192.168.122.133 - - [23/Sep/2015 15:29:48] "POST /v2/36839f2d92c64213b36cc8a619a7ebd1/volumes HTTP/1.1" 500 425 0.100528


Expected results:
Volume is successfully created.

Additional info:
Comment 1 Eric Harney 2015-09-23 10:58:39 EDT
Can you provide an API log with more context and the volume service log?
Comment 2 Javier Peña 2015-09-23 11:28 EDT
Created attachment 1076258 [details]
Cinder logs when reproducing the issue

Please find attached api.log and volume.log, with and without debug enabled in cinder.conf. The procedure I followed in both cases was:

- openstack-service stop cinder
- cleanup logs
- openstack-service start cinder
- cinder create --name test 1
- collect logs
Comment 3 David Moreau Simard 2015-09-25 14:20:42 EDT
Just a hint, haven't found the actual problem or solutoin yet but I am unable to reproduce the issue when installing taskflow 1.20.0, see output: http://paste.openstack.org/show/474055/
Comment 4 David Moreau Simard 2015-09-25 14:37:03 EDT
It looks like the issue is because the networkx-core dependency is outdated from the requirements.txt of taskflow.

taskflow requires networkx>=1.10 and we package/install 1.8.1.
The problem is exhibited in the paste of my previous comment where installing taskflow 1.20.0 picks up an updated networkx dependency.

Installing networkx>=1.10 manually via pip yields a working cinder create with taskflow 1.21.0.
Comment 5 Alan Pevec 2015-09-25 15:42:08 EDT
bummer, networkx-1.10 fails to build in Fedora with
 RuntimeError: Sphinx 1.3 or newer required
https://github.com/networkx/networkx/blob/master/doc/source/conf.py#L38

which conflicts with OpenStack allowed range:
 https://github.com/openstack/requirements/blob/master/global-requirements.txt#L292

Also latest in Fedora is Sphinx 1.2.3
 http://koji.fedoraproject.org/koji/packageinfo?packageID=6297

Haikel, any suggestions how to proceed?

I'll try removing 1.3 req from networkx docs build, failing that, I'd drop docs from the package...
Comment 6 Alan Pevec 2015-09-25 16:47:55 EDT
Here's 1.10 rebase which builds on f22 at least:
https://github.com/apevec/python-networkx/commits/master
- dropped rhel6 support
- adjusted to Sphinx 1.2.3
Comment 7 Alan Pevec 2015-09-26 07:27:38 EDT
> Fixed In Version: python-networkx-1.10-1.el7

TBD fails to build in EL7 buildroot (same with local mockbuild):
http://cbs.centos.org/kojifiles/work/tasks/5109/35109/build.log
Comment 8 Alan Pevec 2015-09-26 16:48:53 EDT
Missing files are in fontawesome-fonts-web which for some reason is pulled into f22 buildroot but not el7?? Quickfix until fully debugged will be explicit BR in python-networkx.spec
Comment 11 David Moreau Simard 2015-09-28 13:42:47 EDT
Just promoted a new set of packages to current-passed-ci which contains the networkx fix. Running a full test now.

Note You need to log in before you can comment on or make changes to this bug.