Bug 1265707 - Wayland: `sudo gvim` can't access the display
Wayland: `sudo gvim` can't access the display
Status: CLOSED DUPLICATE of bug 1274451
Product: Fedora
Classification: Fedora
Component: wayland (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2015-09-23 09:57 EDT by Stephen Gallagher
Modified: 2016-08-31 18:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-31 18:48:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2015-09-23 09:57:32 EDT
Description of problem:
Attempting to run `sudo gvim /path/to/file` returns:
No protocol specified
E233: cannot open displayE852: The child process failed to start the GUI
No protocol specified

And then falls back to the text vim interface, rather than launching the graphical version.


Version-Release number of selected component (if applicable):
wayland-1.8.93-1.fc23.x86_64
sudo-1.8.14p3-1.fc23.x86_64
vim-X11-7.4.827-1.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Install the vim-X11 package
2. Run `sudo gvim /path/to/file`

Actual results:
No protocol specified
E233: cannot open displayE852: The child process failed to start the GUI
No protocol specified

And then falls back to the text vim interface.

Expected results:
The graphical version of gVIM should be launched.

Additional info:
This is a problem only when running under Wayland. It works fine under X11.

I'm not sure what the correct component is, so I'm going with 'wayland'. Please feel free to reassign it as appropriate. I tested this with both gnome-terminal and xterm.
Comment 1 Christian Stadelmann 2016-07-21 11:53:52 EDT
Duplicate of bug #1274451. Wayland doesn't allow any graphical apps to be run as root.
Comment 2 Matthias Clasen 2016-08-31 18:48:25 EDT

*** This bug has been marked as a duplicate of bug 1274451 ***

Note You need to log in before you can comment on or make changes to this bug.