Bug 126571 - A window came up without a decoration frame
A window came up without a decoration frame
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-23 09:21 EDT by Benjamin S. Scarlet
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 00:12:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin S. Scarlet 2004-06-23 09:21:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
A window (acroread) came up for me -- once (sorry) -- without a
decorative frame.  Closing the application and restarting it fixed the
problem.  Could there be some kind unlikely race condition in the code
path for window reparenting?

Version-Release number of selected component (if applicable):
metacity-2.6.3-1

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. Run acroread -- don't know if that's necessary.
2.
3.
    

Actual Results:  The window opened and worked fine, but had no window
manager frame around it.

Expected Results:  The window should have come up with a frame.

Additional info:
Comment 1 Benjamin S. Scarlet 2004-06-23 09:24:15 EDT
I don't know how much of my combination of acroread, metacity, and X
are necessary to cause the problem. It's certainly intermittent and
rare at best.

For the record, I'm using

XFree86-4.3.0-55
acroread-5.0.8-1.rhfc1.dag
Comment 2 Havoc Pennington 2004-11-10 00:12:45 EST
I don't know how to reproduce this, and no other reports of it... I do
believe you, but just not much way to move forward. It could also be
an issue with acroread itself, but no source code on that one.

AFAIK there's no race in the normal case, I think it's more likely
some kind of oddity about acroread.

Would be good to reopen if you can figure out a reliable way to
reproduce (ideally with FC3)
Comment 3 David Sterratt 2005-10-04 11:13:06 EDT
I am able to reproduce this quite (though not totally) reliably using R version
2.1.1 under FC3. In the interactive session pasted below, x11() should bring up
a graphics window with a border. If it does bring up a window on the first time,
try the command a few more times. I find (out of a sample of 25) that it does
about 50% of the time. 

Other R users have also had this problem. They found that using window managers
other than metacity fixed the problem. 

http://tolstoy.newcastle.edu.au/R/help/05/02/12331.html

Here's the interactive R session:

$ R --vanilla

R : Copyright 2005, The R Foundation for Statistical Computing
Version 2.1.1  (2005-06-20), ISBN 3-900051-07-0

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

  Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for a HTML browser interface to help.
Type 'q()' to quit R.

> x11()
> x11()
...

Note You need to log in before you can comment on or make changes to this bug.