Bug 1265716 - Icons related validation not strict enough
Icons related validation not strict enough
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.0-ga
: 3.6.0
Assigned To: jniederm
Karolína Hajná
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 10:11 EDT by jniederm
Modified: 2016-05-19 21:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:55:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46587 None None None Never
oVirt gerrit 46617 ovirt-engine-3.6 MERGED restapi: Fix condition in "IconHelper" Never
oVirt gerrit 46829 refs/tags/ovirt-engine-3.6.0 ABANDONED restapi: Fix condition in "IconHelper" Never
oVirt gerrit 46830 ovirt-engine-3.6.0 MERGED restapi: Fix condition in "IconHelper" Never

  None (edit)
Description jniederm 2015-09-23 10:11:17 EDT
Description of problem:
Meaningless request

PUT /api/vms/{id}
<vm>
    <small_icon />
</vm>

is accepted.

Version-Release number of selected component (if applicable):
3.6 branch, commit 5ef7702

How reproducible:
100%

Steps to Reproduce:
1. Make following request as admin user
PUT /api/vms/{id}
<vm>
    <small_icon />
</vm>


Actual results:
200 ok

Expected results:
400 bad requst
Comment 1 Karolína Hajná 2015-11-13 05:14:02 EST
Verified on ovirt-engine-3.6.0.3-1.el6.noarch
Comment 2 Sandro Bonazzola 2015-11-27 02:55:30 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.