Bug 1265742 - Puppet agent on Sat6 always gives warning
Summary: Puppet agent on Sat6 always gives warning
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.1.2
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Adam Ruzicka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2015-09-23 16:04 UTC by Peter Vreman
Modified: 2019-09-25 20:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:19:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14075 None None None 2016-04-26 17:08:02 UTC
Red Hat Knowledge Base (Solution) 1314253 None None None 2016-03-07 12:48:04 UTC

Description Peter Vreman 2015-09-23 16:04:20 UTC
Description of problem:
A puppet agent run on the Satellite 6 server itself always gives an depreciation warning. The recommended way by puppet to turn the warning off is not possible as there is no global site.pp that is being managed.

# puppet agent -t -v --noop
Info: Retrieving plugin
Info: Loading facts in /var/lib/puppet/lib/facter/root_home.rb
Info: Loading facts in /var/lib/puppet/lib/facter/facter_dot_d.rb
Info: Loading facts in /var/lib/puppet/lib/facter/pe_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardir.rb
Info: Caching catalog for li-lc-1578.hag.hilti.com
Warning: The package type's allow_virtual parameter will be changing its default value from false to true in a future release. If you do not want to allow virtual packages, please explicitly set allow_virtual to false.
   (at /usr/lib/ruby/site_ruby/1.8/puppet/type.rb:816:in `set_default')
Info: Applying configuration version '1443023866'

The only fix is to include the following entry in the /etc/puppet/puppet.conf
disable_warnings = deprecations


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create ContentView A
2. Add couple of puppet modules to ContentView A
3. Publish ContentView A
4. Assign Satellite Server  to ContentView A
5. Run puppet agent -t -v on the Satellite server itself

Actual results:
The warning about allow_virtual is displayed.
The warning is also visible in the Host reports in the UI

Expected results:
No warning is generated by puppet

Additional info:

Comment 2 Marek Hulan 2016-03-07 12:19:02 UTC
Created redmine issue http://projects.theforeman.org/issues/14075 from this bug

Comment 3 Marek Hulan 2016-03-07 12:23:11 UTC
Capsule module does not expose additional settings option of puppet module to users. But since puppet version is under installer control we can enforce this quite safely.

Comment 4 Bryan Kearney 2016-03-07 13:07:55 UTC
Upstream bug component is Content Management

Comment 5 Bryan Kearney 2016-03-08 19:07:17 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14075 has been closed
-------------
Marek Hulán
I don't have permissions to update the category and the PR (which does not seem to be linked), could someone pls move it to Ready for testing and add link to https://github.com/Katello/puppet-capsule/pull/75
-------------
Anonymous
Applied in changeset commit:puppet-capsule|cb5577a2cecd51cccfda238cb2db8fd542afdf36.

Comment 7 Adam Ruzicka 2016-06-13 11:51:26 UTC
VERIFIED.
@Sat6.2.0-Snap15.2

Followed steps to reproduce from #0, no warnings shown, /etc/puppet/puppet.conf contains
disable_warnings = deprecations

Comment 9 errata-xmlrpc 2016-07-27 09:19:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.