This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1265746 - Options 'disable_non_metric_meters' and 'meter_definitions_cfg_file' are missing from ceilometer.conf
Options 'disable_non_metric_meters' and 'meter_definitions_cfg_file' are miss...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Pradeep Kilambi
Yurii Prokulevych
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 12:15 EDT by Yurii Prokulevych
Modified: 2016-04-07 17:08 EDT (History)
3 users (show)

See Also:
Fixed In Version: openstack-ceilometer-5.0.2-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:08:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1499048 None None None Never

  None (edit)
Description Yurii Prokulevych 2015-09-23 12:15:25 EDT
Description of problem:
Options specific to 'Declarative notifications' configurations are missing from ceilometer.conf
Though exist in 
/usr/lib/python2.7/site-packages/ceilometer/meter/notifications.py

Version-Release number of selected component (if applicable):
openstack-ceilometer-api-5.0.0.0b4-dev123.el7.centos.noarch
python-ceilometerclient-1.5.1-dev1.el7.centos.noarch
openstack-ceilometer-common-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-collector-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-polling-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-notification-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-central-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-compute-5.0.0.0b4-dev123.el7.centos.noarch
python-ceilometer-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-alarm-5.0.0.0b4-dev123.el7.centos.noarch


Additional info:
Packstack allinone installation
RHEL 7.1
Comment 1 Pradeep Kilambi 2015-09-23 15:39:23 EDT
fixed upstream: https://review.openstack.org/#/c/226955/3

will hopefully make it into next rc builds.
Comment 4 Yurii Prokulevych 2016-02-24 02:11:42 EST
grep 'meter_definitions_cfg_file' /etc/ceilometer/ceilometer.conf 
#meter_definitions_cfg_file = meters.yaml

grep 'disable_non_metric_meters' /etc/ceilometer/ceilometer.conf
disable_non_metric_meters = True

Verified in ceilometer*-5.0.2-2.el7ost.noarch
Comment 6 errata-xmlrpc 2016-04-07 17:08:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.