Bug 1265749 - RFE:- Option to disable colourful output of journalctl
RFE:- Option to disable colourful output of journalctl
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Synacek
Frantisek Sumsal
Maxim Svistunov
: FutureFeature, Patch, RFE
Depends On:
Blocks: 1203710 1289485 1313485
  Show dependency treegraph
 
Reported: 2015-09-23 12:24 EDT by Rupesh Patel
Modified: 2017-09-15 16:17 EDT (History)
10 users (show)

See Also:
Fixed In Version: systemd-219-20.el7
Doc Type: Release Note
Doc Text:
New variable for disabling colored output for *systemd* This update introduces the `SYSTEMD_COLORS` environment variable for *systemd*, which enables turning on or off *systemd* color output. `SYSTEMD_COLORS` should be set to a valid boolean value.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 20:43:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rupesh Patel 2015-09-23 12:24:11 EDT
By default, journalctl produce colourful output red, while lines based on line of level error, notice etc.... this seems to causing while using non-black screen. I guess it's reasonable request to provide switch (non default) to disable it for users who don't use non-black screen. 

I have checked my F22 and upstream page http://www.freedesktop.org/software/systemd/man/journalctl.html. It looks like not discussed yet anywhere. 

Can we consider this as RFE?

thanks,
Rupesh
Comment 2 Lukáš Nykrýn 2015-09-25 03:25:22 EDT
There must be a way how to achieve tthis without any changes in systemd.
Output there is piped to a pager, so maybe you could just somehow adjust appropriate environment variables.
Comment 3 Karel Zak 2016-01-12 04:15:57 EST
It would be nice to support disable/enable described in "man terminal-colors.d".
Comment 4 Jan Synacek 2016-01-19 04:35:34 EST
https://github.com/systemd/systemd/pull/2364
Comment 7 Jan Synacek 2016-01-20 07:49:10 EST
Merged in https://github.com/systemd/systemd/pull/2381.
Comment 14 errata-xmlrpc 2016-11-03 20:43:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2216.html

Note You need to log in before you can comment on or make changes to this bug.