Bug 126583 - /etc/smartd.conf not configured (well)
/etc/smartd.conf not configured (well)
Status: CLOSED DUPLICATE of bug 110747
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-06-23 12:04 EDT by Jonas Pfenniger
Modified: 2015-01-04 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-01-14 00:19:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jonas Pfenniger 2004-06-23 12:04:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
My disk layout is special, I've had to put the HDD on the secondary
IDE controller, while the CD in on the primary.

During the system boot, the service smartd couldn't start.

I found out /etc/smartd.conf was pointing to /dev/hda and not /dev/hdc
like it should be.
I suppose it's not configured by the install scripts.

Just to tell..


Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:
1. Put your CD-ROM drive on primary and HDD on secondary IDE controller
2. Install FC2

Actual Results:  The daemon smartd doesn't start

Expected Results:  The daemon smartd should start
/etc/smartd.conf should be configured right

Additional info:
Comment 1 Bruce Allen 2004-06-23 12:23:59 EDT
Hi Jonas,

There have been a number of similar reports, about the way in which
/etc/smartd.conf is configured 'out of the box' in Fedora core.  I
don't know if the maintainers plan to change this in the future.  As
you suggest, an installer which configures smartd.conf based on the
machine's hardware would make sense.  An alternative is to use the
DEVICESCAN directive in /etc/smartd.conf, but this could potentially
cause problems with some USB devices (although I think that in recent
smartmontools releases such as 5.30 this is unlikely to happen, since
a great deal of sanity-checking is done).

Comment 2 Jonas Pfenniger 2004-06-24 16:01:28 EDT

Thanks for your advice, I really looked in the search but didn't find
those cases. Too bad, I wanted to post my first real bug :)

Comment 3 will smith 2004-09-11 12:10:48 EDT
Yes, it's basically a duplicate of 
Comment 4 Dave Jones 2005-01-14 00:19:52 EST

*** This bug has been marked as a duplicate of 110747 ***

Note You need to log in before you can comment on or make changes to this bug.