Bug 1265839 - Initialization of bluetooth interface on an Intel Wireless 7265 adapter fails with a timeout error.
Initialization of bluetooth interface on an Intel Wireless 7265 adapter fails...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Don Zickus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 17:57 EDT by Hisham Galal
Modified: 2016-08-04 17:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-04 17:16:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hisham Galal 2015-09-23 17:57:39 EDT
Description of problem: Can't bring up the bluetooth interface on an Intel Wireless 7265 adapter.


Version-Release number of selected component (if applicable): 22, also applies to Rawhire.


How reproducible: Always.


Steps to Reproduce:
1. Run "hciconfig hci0 up" as root.

Actual results: Operation fails with "Can't init device hci0: Connection timed out (110)"

Expected results: Bluetooth interface hci0 should be up and operational.


Additional info: Computer is a fifth-generation Intel NUC (should that be relevant).
Comment 1 Don Zickus 2016-06-30 18:06:45 EDT
Hi,

This is most likely a kernel or firmware issue.  Can you attach the dmesg log?

I am guessing it failed to find the right firmware or the id is not supported
on the kernel you are on.

Cheers,
Don
Comment 2 Don Zickus 2016-08-04 17:16:22 EDT
Hi,

I believe the 7265 was a new bluetooth/wifi card back when this bz was opened.
Since then kernel and firmware support has been added and things should work.
I am using that card in our labs with bluez-5.41 and things are working fine
with a 4.6 kernel.

Therefore I am going to close this.

Cheers,
Don

Note You need to log in before you can comment on or make changes to this bug.