Bug 1265840 - ksnapshot Cannot Take Screenshots Under GNOME/Wayland
ksnapshot Cannot Take Screenshots Under GNOME/Wayland
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ksnapshot (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 18:10 EDT by David Le Sage
Modified: 2015-09-23 19:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 19:50:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Le Sage 2015-09-23 18:10:57 EDT
Description of problem:
If I try to take a screenshot using the "Rectangular Region" option, I cannot do so.  My entire Desktop turns blank (black) and the region I select is also blank.

Version-Release number of selected component (if applicable):
ksnapshot 15.04.2-3.fc23 

How reproducible:
Every time (I have only tried it under GNOME running on Wayland. I haven't tried it in GNOME on X Windows yet or on KDE.)

Steps to Reproduce:
1. Open Firefox under GNOME on Wayland and go to a page you want to capture in a screenshot.
2. Launch ksnapshot.
3. Select the "Rectangular Region" capture mode.
4. Select 1 second as the Snapshot Delay.
5. Click "Take a New Snapshot".

Actual results:
Entire Desktop goes black.  Try to select a region and take a screenshot of it. It also turns out black.

Expected results:
You should be able to take a screensot of the rectangular region you select.

Additional info:
Comment 2 Rex Dieter 2015-09-23 18:20:01 EDT
<nod>, As I understand things, one of the unsolved issues with wayland, is that there is no access to the full screen anymore (due to new security model), so classic (non-wayland) screenshot applications won't work anymore.
Comment 3 Kevin Kofler 2015-09-23 19:50:04 EDT
KSnapshot is X11-only by design, and Wayland does not allow screenshots by design, either. A workaround is planned for Plasma sessions, where "privileged clients" can be supported by kwin_wayland, but I don't think there are any plans to make it work under GNOME.

Note You need to log in before you can comment on or make changes to this bug.